HDU1002 A + B Problem II 大数求和

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author
Ignatius.L

调了很久才AC,坑真的太多了……
盘点一下我遇到的坑:
1.当和是0的时候,输出结果只能是0,不能是000之类的答案;
2.注意进位的处理;
3.各测试用例之间要间隔一个空行。但是!最后一个用例之后不能有空行!!!被这个坑了个PE错误,心塞塞。。。

在大佬的博客里看到的测试用例,附在下面。
0001 1000
0 0
000 0000
9999 1
1 9999
99900 00999
00999 99900

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

void sum(char Min[],char Max[])
{
    int lenmin,lenmax;
    int carry=0;
    lenmin = strlen(Min);
    lenmax = strlen(Max);
    int i;
    int flag = 0;
    for(i=1;i<=lenmin;i++)
    {
        int sum = carry+((int)Min[lenmin-i]-48)+((int)Max[lenmax-i]-48);
        Max[lenmax-i] = (char)(sum%10+48);
        carry = sum/10;
    }
    i--;
    while(carry==1)
    {
        if(i==lenmax)
        {
            cout << '1';
            flag=1;
            break;
        }
        i++;
        int sum = carry + (int)Max[lenmax-i]-48;
        Max[lenmax-i] = (char)(sum%10+48);
        carry = sum/10;
    }

    for(int i=0;i<lenmax;i++)
    {
        if(Max[i]!='0'||flag==1||i==lenmax-1)
            cout << Max[i] , flag=1;
    }
    cout << endl ;

}

int main()
{
    char a[1002],b[1002];
    int n;
    cin >> n;
    for(int t=0;t<n;t++)
    {
        cin >> a;
        cin >> b;
        cout << "Case " << t+1 <<":" << endl;
        cout << a << " + " << b << " = ";
        if(strlen(a)>=strlen(b))    sum(b,a);
        else    sum(a,b);
        if(t!=n-1)  cout << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值