山东省第八届acm大赛 J题 (SDUT 3902)

company

Time Limit: 1000MS  Memory Limit: 65536KB

Problem Description

There are n kinds of goods in the company, with each of them has a inventory of  and direct unit benefit . Now you find due to price changes, for any goods sold on day i, if its direct benefit is val, the total benefit would be ival.
Beginning from the first day, you can and must sell only one good per day until you can't or don't want to do so. If you are allowed to leave some goods unsold, what's the max total benefit you can get in the end?

Input

The first line contains an integers n(1≤n≤1000).
The second line contains n integers val1,val2,..,valn(−100≤.≤100).
The third line contains n integers cnt1,cnt2,..,cntn(1≤≤100).

Output

Output an integer in a single line, indicating the max total benefit.

Example Input
4
-1 -100 5 6
1 1 1 2
Example Output
51
Hint

sell goods whose price with order as -1, 5, 6, 6, the total benefit would be -1*1 + 5*2 + 6*3 + 6*4 = 51.



WA了无数次   最后结果记住要用 long long    



AC代码:

#include <stdio.h>  
#include <algorithm>  
using namespace std;  
  
int cmp(int a,int b){  
    return a>b;  
}  
int main (){  
    int num[1005];  
    int a[100010];  
    int n;  
    scanf ("%d",&n);  
    for (int i=1;i<=n;i++){  
        scanf ("%d",&num[i]);  
    }  
    int len=0;  
    int v;  
    for (int i=1;i<=n;i++){  
        scanf ("%d",&v);  
        while (v--){  
            a[len++]=num[i];  
        }  
    }  
  
    sort(a,a+len,cmp);  
  	//printf("%d\n",len); 
    long long maxn=-999999999;  
    int flag=1;  
    for (int k=len;k>0&&flag;k--)//    要有flag标志位   不然会超时  
    {  
        flag=0;  
        long long sum=0;  
        for (int i=0;i<=k;i++){  
            sum+=(a[i]*(k-i));  
        }  
        if (maxn<sum){  
            flag=1;  
            maxn=sum;  
        }  
    }  
  
    printf ("%lld\n",maxn);  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值