LA4329 Ping pong(树状数组基础)

LA4329 Ping pong

N (3 N 20000) ping pong players live along a west-east street(consider the street as a line segment).
Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If
two players want to compete, they must choose a referee among other ping pong players and hold the
game in the referee’s house. For some reason, the contestants can’t choose a referee whose skill rank is
higher or lower than both of theirs. The contestants have to walk to the referee’s house, and because
they are lazy, they want to make their total walking distance no more than the distance between their
houses. Of course all players live in different houses and the position of their houses are all different. If
the referee or any of the two contestants is different, we call two games different. Now is the problem:
how many different games can be held in this ping pong street?
Input
The rst line of the input contains an integer T (1 T 20), indicating the number of test cases,
followed by T lines each of which describes a test case.
Every test case consists of N + 1 integers. The rst integer is N, the number of players. Then N
distinct integers a1; a2 : : : aN follow, indicating the skill rank of each player, in the order of west to east
(1 ai 100000, i = 1 : : :N).
Output
For each test case, output a single line contains an integer, the total number of different games.
Sample Input
1
3 1 2 3
Sample Output
1

树状数组与组合原理基础题,注意结果要用long long int.

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
int a[20005];
//b[i]表示i左边比i小的个数,d[i]表示i右边比i小的个数
int b[20005];
int d[20005];
int C[100005];
int T,n;
int max_a;
int Sum(int x)
{
      int ret=0;
      while(x>0)
      {
            ret+=C[x];
            x-=x&(-x);
      }
      return ret;
}
int Add(int x,int m)
{
      while(x<=100000)
      {
            C[x]+=m;
            x+=(x&(-x));
      }
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        max_a=0;
        memset(C,0,sizeof(C));
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
           scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)
        {
           Add(a[i],1);
           b[i]=Sum(a[i]-1);
        }
        memset(C,0,sizeof(C));
        for(int i=n;i>=1;i--)
        {
           Add(a[i],1);
           d[i]=Sum(a[i]-1);
        }
        long long  int ans=0;
        for(int i=2;i<n;i++)
        {
           ans+=b[i]*(n-i-d[i])+(i-1-b[i])*d[i];
        }
        printf("%lld\n",ans);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值