poj3348(求凸包的面积)graham算法。

34 篇文章 0 订阅
29 篇文章 0 订阅

Cows
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7157 Accepted: 3285

Description

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.

Sample Input

4
0 0
0 101
75 0
75 101

Sample Output

151

题意就是求凸包的面积除以50即可。真正的graham模板。

#include<limits>
#include<queue>
#include<vector>
#include<list>
#include<map>
#include<set>
#include<deque>
#include<stack>
#include<bitset>
#include<algorithm>
#include<functional>
#include<numeric>
#include<utility>
#include<sstream>
#include<iostream>
#include<iomanip>
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<ctime>
#define LL __int64
#define eps 1e-8
#define pi acos(-1)
using namespace std;
struct point{
	double x,y;
	point (double x=0,double y=0):x(x),y(y){}
};
point p[10010],g[10010];
int dcmp(double x){
	if (fabs(x)<=eps) return 0;
	if (x>0) return 1;
	return -1; 
}
double across(point a,point b,point c){
	return (a.x-c.x)*(b.y-c.y)-(a.y-c.y)*(b.x-c.x);
}
double dis(point a,point b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
bool cmp(point a,point b){
	int k=dcmp(across(a,b,p[0]));
	if (k==-1) return false;
	if (k==0) return dis(a,p[0])<dis(b,p[0]);
	return true;
}
int n,begin;
void graham(){
	g[0]=p[0];
	g[1]=p[1];
	begin=1;
	int l=2;
	while (l<n){
		double d=across(g[begin-1],g[begin],p[l]);
		if (begin >=1 && dcmp(d)<=0) begin--;
		else g[++begin]=p[l++];
	}
}
int main(){
	scanf("%d",&n);
	int k=0,i;
	for (i=0;i<n;i++){
		scanf("%lf%lf",&p[i].x,&p[i].y);
		if (p[k].y>p[i].y || (p[k].y==p[i].y && p[k].x>p[i].x))
			k=i;
	}
	point t=p[k];
	p[k]=p[0];
	p[0]=t;
	sort(p+1,p+n,cmp);
	graham();
	//for (i=0;i<=begin;i++)
	//	cout<<g[i].x<<" "<<g[i].y<<endl;
	double ans=0;
	for (i=2;i<=begin;i++)
		ans+=(fabs(across(g[i-1],g[i],g[0]))/2);
	printf("%d\n",(int)((int)ans/50));
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值