POJ - 3061 Subsequence(尺取法)

Subsequence
Time limit 1000 ms Memory limit 65536 kB

Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3

题目大意:在一个连续的序列中,找到连续的res个数使得他们的sum>=s;

不知道这题暴力能不能过,但是把在这里给大家介绍一种比较巧妙的方法叫做“尺取法”。
尺取法说白了就是自己设一个st,一个ed,然后改变st和ed的大小,来做到这段区间在某一个数列里面移动。
对这道题来讲,我们先通过累加,找到大于s的那个ed,然后再从前先后扫一遍,同时st++,sum-=a[st++],直到sum < s,此时我们便得到了题解的st与ed。(*≧▽≦)ツ

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int zu;
int n,s;
int a[100005];

void solve()
{
    int res=n+1;
    int st=0;
    int ed=0;
    int sum=0;
    for(;;)
    {
        while(ed<n&&sum<s)
        {
            sum+=a[ed++];
        }
        if(sum<s)
            break;
        res=min(res,ed-st);
        sum-=a[st++];
    }
    if(res>n)
        res=0;
    printf("%d\n",res);
}
int main()
{
    scanf("%d",&zu);
    while(zu--)
    {
        scanf("%d%d",&n,&s);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        solve();
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值