POJ 1011

Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 135722 Accepted: 31924
Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.
Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
Output

The output should contains the smallest possible length of original sticks, one per line.
Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
Sample Output

6
5

一道经典的深搜题目。题目大意应该都懂。直接说思路:

1 木棒原长一定是>=给你的最大的棒子的长度,小于所以sticks之和!

2 不要搜索每个长度,只搜索 是总长度因数的长度就好!

3 搜索的时候要注意 当 剩余长度为0时需要把棒子补齐

4 相同长度的棒子只要搜索一次就好!

5 如果你当前的sticks 长度和剩余长度相同或者为0 就不要搜了。直接break;

6 vis数组!注意标记!

#include <string.h>
#include <stdio.h>
#include <iostream>
#include <algorithm>
#define maxs 166
using namespace std;
bool vis[maxs];
int  sticks[maxs];
int sum;
int n;
bool cmp(int a,int b)
{
    return a>b;
}
int dfs(int n_len,int remain_len,int num_stick)
{
    if(remain_len==0&&num_stick==0)
        return n_len;

    if(remain_len==0)
        remain_len=n_len;
    for(int i=0;i<n;i++)
    {
        if(vis[i])
            continue;
        else if(remain_len>=sticks[i])
        {
            vis[i]=true;
            if(dfs(n_len,remain_len-sticks[i],num_stick-1))
                return n_len;
            vis[i]=false;

            if(sticks[i]==remain_len||remain_len==n_len)
                break;
            while(sticks[i]==sticks[i+1])
                i++;

        }
    }
    return 0;
}

int main()
{
 while(~scanf("%d",&n)&&n)
 {
     sum=0;
     for(int i=0;i<n;i++)
     {
         scanf("%d",&sticks[i]);
         sum+=sticks[i];
     }
     int ans=0;
     sort(sticks,sticks+n,cmp);
     for(int len=sticks[0];len<=sum;len++)
     {
         if(sum%len==0)
         {
             memset(vis,false,sizeof(vis));
             ans=dfs(len,0,n);
             if(ans)
                break;
         }
     }
     printf("%d\n",ans);
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值