Weblogic应用程序部署指南

转载 2012年03月26日 19:50:20
1.1    部署JAVA EE应用程序
将编译好的Web应用程序复制到WebLogic的服务器目录下。例如路径D:\bea10\user_projects\domains\base_domain\autodeploy;

这样,当启动WebLogic时候,WebLogic会自动发布该项目。在 WebLogic有个BUG,有时候不能自动发布项目,这时候我们手动修改config.xml配置文件,,配置如下:

<app-deployment>

    <name>_appsdir_QCGroup_dir</name>

    <target>AdminServer</target>

    <module-type>war</module-type>

    <source-path>autodeploy\QCGroup</source-path>

    <security-dd-model>DDOnly</security-dd-model>

    <staging-mode>nostage</staging-mode>

  </app-deployment>

注意:该配置应在<configuration-version>9.2.0.0</configuration-version>和<admin-server-name>AdminServer</admin-server-name>之间
启动服务,在控制台中看到web程序的相关信息,例如日志信息等,说明应用程序已经发布成功。

我不建议使用WebLogic的web控制程序进行部署 ,因为所果出错的话,我们很难找到具体原因

1.2    部署EJB程序
EJB程序的部署与JAVA EE程序的部署相同,只需要更改module-type为ejb即可,如下所示:

  <app-deployment>

    <name>AppEJB</name>

    <target>AdminServer</target>

    <module-type>ejb</module-type>

    <source-path>autodeploy\EJB\appEJB.jar</source-path>

    <security-dd-model>DDOnly</security-dd-model>

  </app-deployment>

1.3    应用程序架构、编译环境及WebLogic版本选择
WebLogic对JDK的适应性相当差,必须使用他自带的JDK版本,或者相同的JDK版本。如果JDK版本不同,会直接导致服务无法启动。

如果web应用程序使用的框架是JDK 1.5或以上的版本,并且XML DTD是2.5或以上的版本。则必须使用WebLogic10 进行部署,否则应用程序无法正常运行,提示项目描述信息出错。即使使用了WebLogic10布署,应用程序也不定可以正常运行,下面的章节将提到。

例如使用了 Struts2框架,如果是WebLogic9或者以下版本,是没法编译Struts2的EL表达式的。

1.4    Hibernate3与WebLogic部署注意事项
Hibernate3与WebLogic部署出现异常:ClassNotFoundException: org.hibernate.hql.ast.HqlToken

Hibernate3.0 采用新的基于ANTLR的HQL/SQL查询翻译器,在Hibernate的配置文件中,hibernate.query.factory_class属性用来选择查询翻译器。
  (1)选择Hibernate3.0的查询翻译器:
    hibernate.query.factory_class= org.hibernate.hql.ast.ASTQueryTranslatorFactory
  (2)选择Hibernate2.1的查询翻译器
   hibernate.query.factory_class= org.hibernate.hql.classic.ClassicQueryTranslatorFactory






为了使用3.0的批量更新和删除功能,

只能选择(1)否则不能解释批量更新的语句,当使用的时候出现了不支持条件输入中文的情况。选择(2)可以支持输入中文,但没法解释批量更新语句了。


    在hibernate3中需要用到antlr,然而这个包在weblogic.jar中已经包含了antrl类库,就会产生一些类加载的错误,无法找到在war或者ear中的hibernate3.jar。
出现这个错误之后,antlr会调用System.exit(),这样weblogic就会中止服务。
解决方法:
    1.是在hibernate.properties文件中增加属性:hibernate.query.factory_class,属性的值是org.hibernate.hql.classic.ClassicQueryTranslatorFactory,这样就可以解决问题了。
但是部分功能会有问题,譬如 但本系在批量删除和更新会有问题,本系统不采用。


    2.将antlr-2.7.5H3.jar到Weblogic的pre_Classpath :用WinRar或Winzip打开C:\bea\weblogic81\server\lib\weblogic.jar 删除里面的antlr目录, 然后再antlr-2.7.5H3.jar放在weblogic.jar的同一目录(注:替换之后没做做过严格测试,尚不知是否有后遗症)


    2.1. 拷贝Hibernate3里带的包antlr-2.7.5H3.jar到%WL_HOME%\server\lib下


    2.2、修改% mydomain% \ startWebLogic.cmd :
       在set CLASSPATH之前加上下面一句(注意包的版本):
       set PRE_CLASSPATH=%WL_HOME%\server\lib\antlr-2.7.6.jar
       在set CLASSPATH之后加上下面一句:
       set CLASSPATH=%PRE_CLASSPATH%;%CLASSPATH%



1.5    JAR包冲突
在weblogic配置文件中去掉如下配置
<container-descriptor>

                     <prefer-web-inf-classes>true</prefer-web-inf-classes>

</container-descriptor>

1.6    weblogic9.2中部署JAVA EE项目
web.xml中配置的schema如果为2.4.xsd,则是j2ee项目,但是目前大多数应用程序都为2.5.xsd,这个时候我们应该将schema改成如下如格式:

<web-app version="2.4" xmlns="http://java.sun.com/xml/ns/j2ee"

     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

     xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee

     http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">



     建议使用weblogic10部署应用程序,因为weblogic9不支持struts2

相关文章推荐

WebLogic部署应用程序.doc

  • 2010-10-11 19:42
  • 1.34MB
  • 下载

linux下weblogic 12c 之应用程序部署

本文档用于指导WebLogic安装,配置,及应用程序部署,常见问题分析和解决

WebLogic:部署应用程序

假设我们现在有两个应用程序的war包: 将这两个war包部署到WebLogic上,通过控制台部署。 点击上载文件,可以将war包上传到管理服务器上, 两个war包的访...

WebLogic部署应用程序(图解)

  • 2011-07-19 10:46
  • 1.35MB
  • 下载

weblogic应用程序部署

  • 2009-01-21 15:28
  • 1.17MB
  • 下载

使用Linux脚本更新Weblogic部署的应用程序

在利用Jenkins实现Weblogic应用自动部署的功能时,如何通过Shell 脚本自动更新Weblogic部署的应用程序呢?可以使用weblogic.jar包中的weblogic.Deployer...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)