hdu1698 Just a Hook(线段树成段更新lazy)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28840    Accepted Submission(s): 14290


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
Case 1: The total value of the hook is 24.

线段树成段更新,lazy标记模板题。。。只是坑点在于。。。 输出最后有个点。。。因为这个wa了4发,始终没找出错误,看了讨论版才看到。。。天坑天坑!!!
#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<stack>
#include<queue>
#include<algorithm>
#include<string>
#include<cstring>
#include<cmath>
#include<vector>
#include<map>
#include<set>
#define eps 1e-8
#define zero(x) (((x>0?(x):-(x))-eps)
#define mem(a,b) memset(a,b,sizeof(a))
#define memmax(a) memset(a,0x3f,sizeof(a))
#define pfn printf("\n")
#define ll __int64
#define mod 1000000007
#define sf(a) scanf("%d",&a)
#define sf64(a) scanf("%I64d",&a)
#define sf264(a,b) scanf("%I64d%I64d",&a,&b)
#define sf364(a,b,c) scanf("%I64d%I64d%I64d",&a,&b,&c)
#define sf2(a,b) scanf("%d%d",&a,&b)
#define sf3(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define sf4(a,b,c,d) scanf("%d%d%d%d",&a,&b,&c,&d)
#define sff(a) scanf("%f",&a)
#define sfs(a) scanf("%s",a)
#define sfs2(a,b) scanf("%s%s",a,b)
#define sfs3(a,b,c) scanf("%s%s%s",a,b,c)
#define sfd(a) scanf("%lf",&a)
#define sfd2(a,b) scanf("%lf%lf",&a,&b)
#define sfd3(a,b,c) scanf("%lf%lf%lf",&a,&b,&c)
#define sfd4(a,b,c,d) scanf("%lf%lf%lf%lf",&a,&b,&c,&d)
#define sfc(a) scanf("%c",&a)
#define debug printf("***\n")
const double PI = acos(-1.0);
const double e = exp(1.0);
const int INF = 0x7fffffff;;
template<class T> T gcd(T a, T b) { return b ? gcd(b, a % b) : a; }
template<class T> T lcm(T a, T b) { return a / gcd(a, b) * b; }
template<class T> inline T Min(T a, T b) { return a < b ? a : b; }
template<class T> inline T Max(T a, T b) { return a > b ? a : b; }
bool cmpbig(int a, int b){ return a>b; }
bool cmpsmall(int a, int b){ return a<b; }
using namespace std;
#define MAX 100010
struct arnode
{
    int left,right;
    int num;
    int lazy;//懒惰标记
    int tag;//若需更新,则更新为tag值
    arnode(int left=0,int right=0,int num=0,int lazy=0,int tag=0):left(left),right(right),num(num),lazy(lazy),tag(tag){}
}tree[4*MAX];
void buildtree(int root,int l,int r)
{
    tree[root].left=l;tree[root].right=r;tree[root].lazy=tree[root].tag=0;
    if(l==r)
    {
        tree[root].num=1;
        return ;
    }
    int mid=(l+r)>>1;
    buildtree(root<<1,l,mid);
    buildtree((root<<1)+1,mid+1,r);
    tree[root].num=tree[root*2].num+tree[root*2+1].num;
    return ;
}
void updata(int root,int l,int r,int v)
{
   //printf("%d %d %d\n",root,l,r);
    if(tree[root].left==l&&tree[root].right==r)
    {
        tree[root].num=(r-l+1)*v;
        tree[root].lazy=1;
        tree[root].tag=v;
        return ;
    }
    int mid=(tree[root].right+tree[root].left)>>1;
    if(tree[root].lazy==1)
    {
        tree[root].lazy=0;
        updata(root<<1,tree[root].left,mid,tree[root].tag);
        updata((root<<1)+1,mid+1,tree[root].right,tree[root].tag);
        tree[root].tag=0;
    }
    if(mid<l)
        updata((root<<1)+1,l,r,v);
    else if(r<=mid)
        updata(root<<1,l,r,v);
    else
    {
        updata(root<<1,l,mid,v);
        updata((root<<1)+1,mid+1,r,v);
    }
    tree[root].num=tree[root<<1].num+tree[(root<<1)+1].num;
    return ;
}
int main()
{
   // freopen("data.in","r",stdin);
    int t,tot=1;
    sf(t);
    while(t--)
    {
        int n;
        sf(n);
        buildtree(1,1,n);
        int q;sf(q);
        while(q--)
        {
            int l,r,v;
            sf3(l,r,v);
            //printf("%d\n",q);
            updata(1,l,r,v);
        }
        printf("Case %d: The total value of the hook is %d.\n",tot++,tree[1].num);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值