对n的阶乘取余

点击打开链接

Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case, output N! mod 2009
 

Sample Input
  
  
4 5
 

Sample Output
24
120

#include<cstdio>
#define LL long long

const int mod = 2009;
int main()
{
    LL n;
    while(~scanf("%lld",&n)) 
	{
        if(n >= mod) puts("0");//此处mod可以改为41,因为之前已经有个数可以整除 
        else {				// 2009,7*7*41=2009;
            LL ans = 1;
            for(int i = n; i>1; i--) {
                ans = (ans*(i%mod))%mod;//ans=(ans%mod*i%mod)%mod;
            }
            printf("%lld\n",ans);
        }

    }
    return 0;
 } 

  
  


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值