ZOJ 1002 Fire Net【dfs】



Fire Net

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4


题目大意:有一正方形的城市,街道都是值的,现输入一个n,作为城市的规模,然后再输入城市的分布,'.' 表示空路,'X'表示墙,现要在城市的空路上建碉堡。在建碉堡时,不能把两个碉堡建在同一直线上,除非两个碉堡中间有墙 ‘X' 隔开,【0<=n <=4】,n==0时,结束程序。


解析:为了避免空格干扰,所以用c++的cin刚刚好。

          设n==4,从左上角(0,0),开始,然后从左到右,再从上到下到(3,3) ,逐个遍历。

         从(0,0)开始, ★从当前格子开始向四个方向遍历,

                                        if 在没有墙的间隔时当前行或列已有碉堡【不合法】,则这个格子poss,转到下一个格子;

                                        else 【合法】,当前格子有两种方案,建或不建,

                                                       建,然后再转到下一格,

                                                      不建,再转到下一格

                                     重复★,直到(3,3);

已Accept【c++提交】

#include <iostream>
using namespace std;

char map[5][5];
int n, m;

bool Solve(int x, int y) {
	for(int i = x - 1; i >= 0; i--) {
		if(map[i][y] == 'F')
			return false;
		if(map[i][y] == 'X')
			break;
	}
	for(int i = x + 1; i < n; i++) {
		if(map[i][y] == 'F')
			return false;
		if(map[i][y] == 'X')
			break;
	}
	for(int i = y - 1; i >= 0; i--) {
		if(map[x][i] == 'F')
			return false;
		if(map[x][i] == 'X')
			break;
	}
	for(int i = y + 1; i < n; i++) {
		if(map[x][i] == 'F')
			return false;
		if(map[x][i] == 'X')
			break;
	}
	return true;
}

void DFS(int x, int y, int a) {
	if(x == n - 1 && y == n - 1) {
		if(map[x][y] == '.' && Solve(x, y))
			a++;
		if(a > m)
			m = a;
		return ;
	}
	if(map[x][y] == '.' && Solve(x, y)) {
		map[x][y] = 'F';
		if(y == n - 1) 
			DFS(x + 1, 0, a + 1);
		else
			DFS(x, y + 1, a + 1);
		map[x][y] = '.';
		if(y == n - 1) 
			DFS(x + 1, 0, a);
		else
			DFS(x, y + 1, a);
	}
	else {
		if(y == n - 1) 
			DFS(x + 1, 0, a);
		else
			DFS(x, y + 1, a);
	}
}

int main() {
	while(cin >> n, n) {
		for(int i = 0; i < n; i++)
			for(int j = 0; j < n; j++)
				cin >> map[i][j];
		m = 0;
		DFS(0, 0, 0);
		cout << m << endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值