hdu 3292 佩尔方程一系列操作

No more tricks, Mr Nanguo

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 445 Accepted Submission(s): 294

Problem Description
Now Sailormoon girls want to tell you a ancient idiom story named “be there just to make up the number”. The story can be described by the following words.
In the period of the Warring States (475-221 BC), there was a state called Qi. The king of Qi was so fond of the yu, a wind instrument, that he had a band of many musicians play for him every afternoon. The number of musicians is just a square number.Beacuse a square formation is very good-looking.Each row and each column have X musicians.
The king was most satisfied with the band and the harmonies they performed. Little did the king know that a member of the band, Nan Guo, was not even a musician. In fact, Nan Guo knew nothing about the yu. But he somehow managed to pass himself off as a yu player by sitting right at the back, pretending to play the instrument. The king was none the wiser. But Nan Guo’s charade came to an end when the king’s son succeeded him. The new king, unlike his father, he decided to divide the musicians of band into some equal small parts. He also wants the number of each part is square number. Of course, Nan Guo soon realized his foolish would expose, and he found himself without a band to hide in anymore.So he run away soon.
After he leave,the number of band is Satisfactory. Because the number of band now would be divided into some equal parts,and the number of each part is also a square number.Each row and each column all have Y musicians.

Input
There are multiple test cases. Each case contains a positive integer N ( 2 <= N < 29). It means the band was divided into N equal parts. The folloing number is also a positive integer K ( K < 10^9).

Output
There may have many positive integers X,Y can meet such conditions.But you should calculate the Kth smaller answer of X. The Kth smaller answer means there are K – 1 answers are smaller than them. Beacuse the answer may be very large.So print the value of X % 8191.If there is no answers can meet such conditions,print “No answers can meet such conditions”.

Sample Input
2 999888
3 1000001
4 8373

Sample Output
7181
600
No answers can meet such conditions

#include <cstdio>    // 当 x^2-D*y^2=1 D 很大时(D>1000)需要用大数
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <iostream>
using namespace std;
typedef long long ll;
const int mod =  8191;
ll a[20000];
vector<ll> xx,yy;
struct matrix{
    int m[2][2];
}ans,bs;
matrix multi(matrix a,matrix b){
    matrix c;
    for(int i = 0; i < 2; i++){
        for(int j = 0; j< 2; j++){
            c.m[i][j] = 0;
            for(int k = 0; k< 2; k++){
                c.m[i][j] = (c.m[i][j]+a.m[i][k]*b.m[k][j])%mod;
            }
        }
    }
    return c;
}
int fast_mod(ll x,ll y,ll d,ll n){
    bs.m[0][0]=x; bs.m[0][1]=d*y;
    ans.m[0][0]=ans.m[1][1]=1;
    bs.m[1][0]=y; bs.m[1][1]=x;
    ans.m[0][1]=ans.m[1][0]=0;
    while(n){
        if(n&1)
        ans=multi(ans,bs);
        bs=multi(bs,bs);
        n>>=1;
    }
    printf("%lld\n",(ans.m[0][0]*x+ans.m[0][1]*y)%mod);
    return ans.m[0][1];
}
bool pell_minimum_solution(ll n,ll &x0,ll &y0){
    ll m=(ll)sqrt((double)n);
    double sq=sqrt(n);
    int i=0;
    if(m*m==n)return false;
    a[i++]=m;
    ll b=m,c=1;
    double tmp;
    do{
        c=(n-b*b)/c;
        tmp=(sq+b)/c;
        a[i++]=(ll)(floor(tmp));
        b=a[i-1]*c-b;
    }while(a[i-1]!=2*a[0]);
    ll p=1,q=0;
    for(int j=i-2;j>=0;j--){
        ll t=p;
        p=q+p*a[j];
        q=t;
    }
    if((i-1)%2==0){x0=p;y0=q;}
    else{x0=2*p*p+1;y0=2*p*q;}
    return true;
}
void get(ll x,ll y,ll d,int n)  //利用特解求n个通解;
{
    xx.push_back(x);yy.push_back(y);
    for (int i=1;i<=n;i++)
    {
        xx.push_back(xx[i-1]*x+d*yy[i-1]*y);
        yy.push_back(xx[i-1]*y+yy[i-1]*x);
    }

}
void getk(ll x,ll y, ll d,ll k) //矩阵快速幂求出第k大的解.
{
    fast_mod(x,y,d,k-1);
}
int main(){
    ll n,x,y,k;
    while(~scanf("%lld %lld",&n,&k)){
        if(pell_minimum_solution(n,x,y)){
                getk(x,y,n,k);
        }else
        printf("No answers can meet such conditions\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值