POJ 3261 Milk Patterns (后缀数组或HASH,4级)

G - Milk Patterns
Crawling in process... Crawling failed Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description:

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ KN) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K
Lines 2.. N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4
思路:二分长度,判断符合条件不,后缀数组和HASH都行
 
   
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#define FOR(i,a,b) for(int i=a;i<=b;++i)
#define clr(f,z) memset(f,z,sizeof(f))
#define LL unsigned long long
using namespace std;
const int mm=2e4+9;
const int mod=127;
LL h[mm],xp[mm],has[mm];
int rank[mm],f[mm];
int N,K;
bool cmp(const int&a,const int&b)
{
  return has[a]<has[b]||(has[a]==has[b]&&a<b);
}
bool ok(int mid,int k)
{
  for(int i=0;i<N-mid+1;++i)
  {
    rank[i]=i;
    has[i]=h[i]-h[i+mid]*xp[mid];
  }
  sort(rank,rank+N-mid+1,cmp);
  int num=0;
  for(int i=0;i<N-mid+1;++i)
  {
    if(i==0||has[ rank[i] ]!=has[ rank[i-1] ])num=0;
    if(++num>=k)return 1;
  }
  return 0;
}
int main()
{
  while(~scanf("%d%d",&N,&K))
  {
    FOR(i,0,N-1)scanf("%d",&f[i]);
    h[N]=0;
    for(int i=N-1;i>=0;i--)
      h[i]=h[i+1]*mod+f[i];
    xp[0]=1;
    FOR(i,1,N)xp[i]=xp[i-1]*mod;
    int l=1,r=N,mid;
    int ans=0;
    //if(ok(4,2))puts("+++|");
    while(l<=r)
    {
      mid=(l+r)/2;
      if(ok(mid,K))
      { ans=max(ans,mid);
        l=mid+1;
      }
      else r=mid-1;
    }
    printf("%d\n",ans);
  }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值