uvaoj-133:约瑟夫环的模拟

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.


题解:刘汝佳白书82页例题4-3,思路就是模拟运行,利用自定义函数可以是程序更加美观;


code:

#include <cstdio>
#include <cstring>
#include <cmath>
#define maxn 25

int n,k,s[maxn],m;
int go(int start,int dir,int step);//声明函数;
int main()
{
    while(~scanf("%d%d%d",&n,&k,&m)&&n)
    {
        int left=n;
        for(int i=1; i<=20; i++)//将数据存入数组以便在循环的时候跳过;
        s[i]=i;

        int a=n;
        int b=1;
        while(left)
        {
            a=go(a,1,k);//三个变量分别代表:初始位置、方向、步幅;
            b=go(b,-1,m);
            printf("%3d",a);
            left--;
            if(b!=a)
            {
                printf("%3d",b);
                left--;
            }
            s[a]=s[b]=0;//将已经数过的人变为零避免下次循环的时候再次数发生错误;
            if(left)
            printf(",");
        }
        printf("\n");
    }
    return 0;
}
int go(int start,int dir,int step)//A,B两个人的方向正好相反,可以用正负1分别代表方向;
{
    while(step--)//每次只数一个,数step次;
    {
        do
        {
            start=(start+n-1+dir)%n+1;//这里加一减一来避免出现start为零的情况;
        }
        while(s[start]==0);//do-while语句是先运行再判断,利用do-while将圈内已经数过的人跳过;
    };
    return start;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值