九度 OJ 1162 I Wanna Go Home 最短路问题

题目链接:http://ac.jobdu.com/problem.php?pid=1162


题目描述:

    The country is facing a terrible civil war----cities in the country are divided into two parts supporting different leaders. As a merchant, Mr. M does not pay attention to politics but he actually knows the severe situation, and your task is to help him reach home as soon as possible. 
    "For the sake of safety,", said Mr.M, "your route should contain at most 1 road which connects two cities of different camp."
    Would you please tell Mr. M at least how long will it take to reach his sweet home?

输入:

    The input contains multiple test cases.
    The first line of each case is an integer N (2<=N<=600), representing the number of cities in the country.
    The second line contains one integer M (0<=M<=10000), which is the number of roads.
    The following M lines are the information of the roads. Each line contains three integers A, B and T, which means the road between city A and city B will cost time T. T is in the range of [1,500].
    Next part contains N integers, which are either 1 or 2. The i-th integer shows the supporting leader of city i. 
    To simplify the problem, we assume that Mr. M starts from city 1 and his target is city 2. City 1 always supports leader 1 while city 2 is at the same side of leader 2. 
    Note that all roads are bidirectional and there is at most 1 road between two cities.
Input is ended with a case of N=0.

输出:

    For each test case, output one integer representing the minimum time to reach home.
    If it is impossible to reach home according to Mr. M's demands, output -1 instead.

样例输入:
2
1
1 2 100
1 2
3
3
1 2 100
1 3 40
2 3 50
1 2 1
5
5
3 1 200
5 3 150
2 5 160
4 3 170
4 2 170
1 2 2 2 1
0
样例输出:
100
90
540
     此题属于单源最短路径问题,只是构建图时要做一些小改动,因为主人公不想来回穿越两军的地盘,有要从1到2,所以要想办法把阵营2到阵营1的路径设为不可到达,我在这是把边权值设为0办法,求最短路时判0跳过。图构建完之后再用Dijsktra最短路算法求得最短路。

#include <stdio.h>
#include <vector>
using namespace std;
struct E{
	int next;
	int t;
};
vector <E> edge[610];
bool mark[610];
int time[610];
int owner[610];
int main(){
	int n,m;
	while(scanf("%d",&n)!=EOF && n!=0){
		scanf("%d",&m);
		for(int i=1;i<=n;i++){
			edge[i].clear();
		}
		int a,b,t;
		for(int i=0;i<m;i++){
			scanf("%d%d%d",&a,&b,&t);
			E tmp;
			tmp.next=b;
			tmp.t=t;
			edge[a].push_back(tmp);
			tmp.next=a;
			edge[b].push_back(tmp);
		}
		for(int i=1;i<=n;i++){
			mark[i]=false;
			time[i]=-1;
			scanf("%d",&owner[i]); 
		}
		for(int i=1;i<=n;i++){
			if(owner[i]==2){
				for(int j=0;j<edge[i].size();j++){
					if(owner[edge[i][j].next]==1){
						edge[i][j].t=0;
					}
				}
			}
		}
		time[1]=0;
		mark[1]=true;
		int newp=1;
		for(int i=1;i<n;i++){
			for(int j=0;j<edge[newp].size();j++){
				int next_=edge[newp][j].next;
				int time_=edge[newp][j].t;
				if(mark[next_]==true)
					continue;
				if(time_==0)
					continue;
				if(time[next_]==-1 || time[next_]>time[newp]+time_){
					time[next_]=time[newp]+time_;
				}
			}
				int min=1000;
				for(int j=1;j<=n;j++){
					if(mark[j]==true)
						continue;
					if(time[j]==-1)
						continue;
					if(time[j]<min){
						min=time[j];
						newp=j;
					}
				}
				mark[newp]=true;
			}
			if(time[2]!=-1)
				printf("%d\n",time[2]);
			else
				printf("-1\n");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值