POj 3250 Bad Hair Day (思维+单调栈)

Bad Hair Day
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19167 Accepted: 6522
Description


Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.


Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.


Consider this example:


        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!


Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.


Input


Line 1: The number of cows, N. 
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
Output


Line 1: A single integer that is the sum of c1 through cN.
Sample Input

6
10
3
7
4
12
2
Sample Output

5


题意就是牛都朝右,然后把每头牛往右可以看到的牛数加起来就得到结果。


题解:

如果单纯地把每头牛都往右看,看看有多少牛比他要矮,很容易超时。

所以我们可以想,能不能扫一遍记录下每头牛被可以被多少头牛看到,岂不是更简单。

这里我们用贡献的思想,用一个严格单减的单调栈,每一头牛把栈内比它矮的牛都除去,剩下的牛就是能看到它的。O(N)的复杂度即解决。


附上代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<stack>
using namespace std;
int main()
{
	int n;
	int a[80005];
	long long ans = 0;
	
	cin>>n;
	stack<int> q;
	while(!q.empty())
		q.pop();//清空栈
	
	for(int i = 1;i<= n;i++)
		scanf("%d",&a[i]);
	for(int i = 1;i<= n;i++)
	{
		while(!q.empty()&&a[i]>= q.top())
			q.pop();//除去比这头牛矮的所有牛(即除去不符合条件的量)
		ans+= q.size();//把能看到它的牛的数量加进结果
		q.push(a[i]);
	}
	cout<<ans<<endl;
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值