HDU-1260 Tickets(DP)

24 篇文章 0 订阅
10 篇文章 0 订阅

HDU-1260 Tickets(DP)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
Sample Input
2
2
20 25
40
1
8
Sample Output
08:00:40 am
08:00:08 am

题意:在已知单人买票等候时间a[i] 和 相邻双人票等候时间b[i] 的情况求最短的等候时间。最优解的话,用dp,主要是状态方程,dp[i]表示当前状态i人的等候时间【最优解】 此时要考虑两种情况,此时单独买第i人的票时间为a[i],或者是买第i-1人与第i人双人票时间为b[i],即dp[i] = min(dp[i-1]+a[i] , dp[i-2]+b[i-1]) ,此外 dp的出口是第1人为a[i] 或者 是第2人min(团票b[1],单独买a[1]+a[2])。

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <ctime>
#include <set>
#include <map>
#include <cmath>
using namespace std;
#define BUG puts("here!!!")
#define W(a) while(a--)
#define FRead() freopen("in", "r", stdin)
#define FWrite() freopen("out", "w", stdout)
#define Cls(a) memset((a), 0, sizeof(a))
#define Clr(a, x) memset((a), (x), sizeof(a))
#define pi 3.14159265359
typedef long long LL;
const int maxn = 3100;
int n, h, k;
int a[maxn],b[maxn],dp[maxn];
int min(int a,int b){
    return a<b?a:b;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        a[0] = 0;
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        for(int i=1;i<n;i++){
            scanf("%d",&b[i]);
        }
//      cout<<"***"<<endl;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++){
            if(i==1){
                dp[i] = a[i];
                continue;
            }
            if(i==2){
                if(dp[i-1]+a[i]<=b[i-1]){
                    dp[i] = dp[i-1]+a[i];
                }
                else{
                    dp[i] = b[i-1];
                }
                continue;   
            }
            dp[i] = min(dp[i-1]+a[i] , dp[i-2]+b[i-1]);

        }
//      printf("%d\n",dp[n]);
        int sum = dp[n];
        int hh,mm,ss;
        hh = mm = ss = 0;
        if(sum>=3600) {
            hh = sum/3600;
            sum -= hh*3600;
        }
        if(sum>=60){
            mm = sum / 60;// 100/60 = 1
            sum -= mm*60;
        } 
        ss = sum;
        hh = (hh+8)%24;
        if(hh>=12&&hh!=0) 
            printf("%02d:%02d:%02d pm\n",hh,mm,ss);
        else 
            printf("%02d:%02d:%02d am\n",hh,mm,ss);

    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值