【HDU】1171【母函数】【Big Event in HDU】

          Big Event in HDU

TimeLimit: 10000/5000 MS(Java/Others)    MemoryLimit: 65536/32768 K (Java/Others)
Total Submission(s):9181    AcceptedSubmission(s): 3173


ProblemDescription
Nowadays, we all know thatComputer College is the biggest department in HDU. But, maybe youdon't know that Computer College had ever been split into ComputerCollege and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time,it is a trouble thing too. All facilities must go halves. First,all facilities are assessed, and two facilities are thought to besame if they have the same value. It is assumed that there is N(0<N<1000) kinds of facilities(different value, different kinds).
 

Input
Input contains multiple testcases. Each test case starts with a number N (0 < N<= 50 -- the total number of different facilities).The next N lines contain an integer V(0<V<=50 --value of facility) and aninteger M (0<M<=100 --correspondingnumber of the facilities) each. You can assume that all V aredifferent.
A test case starting with a negative integer terminates input andthis test case is not to be processed.
 

Output
For each case, print one linecontaining two integers A and B which denote the value of ComputerCollege and Software College will get respectively. A and B shouldbe as equal as possible. At the same time, you should guaranteethat A is not less than B.
 

SampleInput
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

SampleOutput
20 10 40 40

#include <iostream>
#include <cstdio>
using namespace std;
int date_value[51],date_num[51];//价值及个数
int c1[150000],c2[150000];//组成的最后价值
intmain(){
   int n;
   while(scanf("%d",&n),n>0){
       int i=0,j,k,len;
       memset(c1,0,sizeof(int)*130000);
       while(i<n){
           scanf("%d%d",&date_value[i],&date_num[i]);
           i++;
       }
       len=0;
       for(i=0;i<n;i++){
           c1[0]=1;
           len+=date_value[i]*date_num[i];
           for(j=0;j<=len;j++){
               for(k=0;k<=date_num[i];k++)
                   c2[k*date_value[i]+j]+=c1[j];
           }
           for(j=0;j<=len;j++){
               c1[j]=c2[j];
               c2[j]=0;
           }
       }
       for(i=len/2;i>=0;i--)
           if(c1[i]){
               printf("%d%d\n",len-i,i);
               break;
           }
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值