关闭

我遇到的Android安装问题

295人阅读 评论(0) 收藏 举报
分类:
   去年10.1开始接触android,第一个问题就是安装问题,整整摆弄了两天,才搞定,想起来真是不堪回首。到现在完成了第一个项目,中间遇到了各种状况,大部分都是看帖子解决的。所以我决定把我遇到的问题都写出来,取之于网络还与之网络,嘿嘿,希望能帮到和我遇到一样问题的朋友。
   安装android一般流程就不说了,网上太多了,我遇到的问题是:我遇到下载SDK太慢,我下了一天,没下多少,急了就找了网上的手动配置。

步骤:
下载需要更新的文件。打开https://dl-ssl.google.com/android/repository/repository.xml, 你可以找到需要下载的文件。在文件名前面加上https://dl-ssl.google.com/android/repository即是绝对路径。

比如:

https://dl-ssl.google.com/android/repository/android-2.2_r02-windows.zip

https://dl-ssl.google.com/android/repository/google_apis-8_r02.zip


2. 将文件下载下来后放到android sdk的temp目录下,然后运行SDK Setup.exe去更新,你会发现SDK会很快更新好了。

 

 

另外如果你更新了SDK,再重新启动,有时候Eclipse会提示ADT的版本过低,就像这样。
更新Android <wbr><wbr>SDK之后Eclipse提示ADT版本过低的一个简易解决办法

但是ADT 10.0.0 或者更高的版本又不是那么容易获得,从现有的Eclipse里面更新很有难度,google更新太不给力,所以就要手工处理一下了。我又在网上找到的解决办法
更新Android <wbr><wbr>SDK之后Eclipse提示ADT版本过低的一个简易解决办法
更新之后可以看到,出问题了,10.0.0,没错,就是那里,
每次更新之后%android_home%\tools\lib目录下的“plugin.prop”里面那句就会变成10.0.0,如果不改,系统就会认为版本过低,要用低版本的Eclipse开发,只要改成" plugin.prop.plugin.version=9.0.0”即可。(啰嗦一下,%android_home%就是SDK所在的目录哦)
来一张图
更新Android <wbr><wbr>SDK之后Eclipse提示ADT版本过低的一个简易解决办法

没错,就这样简单,改了之后重启Eclipse,进去设置就没问题了~

或者你找到相应的adt版本就可以了。

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:24140次
    • 积分:202
    • 等级:
    • 排名:千里之外
    • 原创:95篇
    • 转载:1篇
    • 译文:0篇
    • 评论:0条
    文章分类
    文章存档