Android Support Library更新到v22.1之AppCompat新特性

转载 2015年07月08日 15:20:04

构建一个可以跑在不同版本 Android 平台的软件,是非常复杂和耗时的。为了解决这个问题,Android 推出了 Android Support Library (安卓兼容包),让新的UI控件也可以跑在早期的 Android 版本。最近Android Support Library 更新到v22.1,这一版本主要AppCompat做了一些大的调整。

重构AppCompat

初期AppCompat只是让Actionbar兼容到API 7。在AppCompat 21版本中,加入主题色、Toolbar等功能。显然ActionBarActivity这个名字已经不在适用AppCompat。新版本中,推荐使用AppCompatActivity 代替ActionBarActivity。

android:theme

新版本AppCompat 允许对 Toolbar 使用 android:theme代替 app:theme. 兼容 API11+.

 <android.support.v7.widget.Toolbar
                xmlns:android="http://schemas.android.com/apk/res/android"
                android:id="@+id/main_drawer_toolbar"
                android:layout_width="match_parent"
                android:layout_height="?attr/actionBarSize"
                android:layout_below="@+id/main_statusBar"
                android:background="?attr/colorPrimary"
                android:translationZ="4dp"
                android:popupTheme="@style/ThemeOverlay.AppCompat.Light"
                android:theme="@style/ThemeOverlay.AppCompat.Dark.ActionBar"/>

AppCompatDialog对话框

终于加入MD对话框和新主题theme Theme.AppCompat.Dialog
使用

  AlertDialog.Builder builder = new AlertDialog.Builder(this);
        builder.setTitle("Dialog");
        builder.setMessage("少数派客户端");
        builder.setPositiveButton("OK", null);
        builder.setNegativeButton("Cancel", null);
        builder.show();

具体效果

图片描述

原文http://segmentfault.com/a/1190000002702843

相关文章推荐

Android support library 23.2新特性介绍

昨天Android官网更新了support library 23.2版本。本文翻译自官方博客,介绍了新发布的支持库的几个新特性。

android7新特性之 support library 25.0.0

前言转眼间2016年还有两个月就完事了,Android移动开发也已经走过了第八个年头了。伴随着Android 7.1(API 25.0.0)的发布,一系列开发相关的开发工具和类库也一起更新了,今天我们...

Android Support Library 22.1

  • 2015-04-23 16:49
  • 1.10MB
  • 下载

Error:Failed to resolve: com.android.support:appcompat-v7:25.+d

当我新创建一个Android 项目时,提示一个错误如下: 错误提示说没有安装 Repository,然后我通过SDK Manager 下载 Android Support Repository ...

eclipse导入android-support-v7-appcompat报错问题

eclipse导入android-support-v7-appcompat后报如下错误 在这里报错:报错原因是android源程序找不到这个Material(这是android L新特性;,我们大...

项目中导入ActionBar的android-support-v7-appcompat.jar包

在Android低版本中要使用ActionBar就要导入android-support-v7-appcompat.jar包,但是用以往的方法把android-support-v7-appcompat....

聊一聊android.support.v7包下的AppCompat

其实之前大家在用AndroidStudio创建一个新的项目的时候有没有发现谷歌爸爸自动给你继承了AppComatActivity。而且有些时候你会发现莫名其妙的报很多错。然后就开始把谷歌爸爸帮你创建的...

Android Studio新建工程Gradle编译报错(com.android.support:appcompat-v7:16.+)

以前的Android开发都是在Eclipse中,其缺点是Eclipse的大而全,对Android来说不够专业,还需要加入插件才可以支持,运行速度慢,调试不方便。为此Google重新研发了针对Andro...

Could not find android-support-v7-appcompat.apk!android问题

之前遇到的问题,在万能的stackoverflow上面找到了答案,哈哈 原文网址:http://stackoverflow.com/questions/18421274/android-could-n...

Android Studio Error:Failed to resolve: com.android.support:appcompat-v7:25.1.0

今天不知道为什么导入eclipse项目后就出现了错误,没导入之前是正常使用AS的 Error:(26, 13) Failed to resolve: com.android.support:appc...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)