HDU 2594Simpsons’ Hidden Talents(KMP运用)

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1716    Accepted Submission(s): 619


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
  
  
clinton homer riemann marjorie
 

Sample Output
  
  
0 rie 3
 

          题目大意:给你a,b两个串,求出a串的前缀与b串后缀最长的公共串。
       
      解题思路:由于是求b的后缀最长是a的前缀。不妨将a,b连接起来,求next数组,这样next[len](len表示a,b连接后的长度)则可以表示匹配到的最大长度。 不过需要注意的是next[len]不能大于a,b的长度。

      题目地址:Simpsons’ Hidden Talents
AC代码:
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
using namespace std;
char a[100005],b[50005]; 
int next[100005],len,len1,len2;

void getnext()
{
     int i,j;
     //memset(next,0,sizeof(next));
     next[0]=0,next[1]=0; 
     for(i=1;i<len;i++)
     {
          j=next[i];
          while(j&&a[i]!=a[j])
             j=next[j];
          if(a[i]==a[j])
             next[i+1]=j+1;
            else
               next[i+1]=0;
     } 
}

int main()
{
     while(~scanf("%s%s",a,b))
     {
          len1=strlen(a),len2=strlen(b),len=len1+len2;
          strcat(a,b);
          getnext();
          int i,j=next[len];
          while(j>len1||j>len2)
                j=next[j];    //防止aaa aaaa这种情况
          for(i=0;i<j;i++)
            printf("%c",a[i]);
          if(j)
             printf(" ");
          printf("%d\n",j);
     }
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值