the SetStack computer

The SetStack Computer

Background from Wikipedia: “Set theory is a branch of mathematics created principally by the German mathematician Georg Cantor at the end of the 19th century. Initially controversial, set theory has come to play the role of a foundational theory in modern mathematics, in the sense of a theory invoked to justify assumptions made inmathematics concerning the existence of mathematical objects (such as numbers or functions) and their properties. Formal versions of set theory also have a foundational role to play as specifying a theoretical ideal of mathematical rigor in proofs.”

Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to construct a supercomputer operating on sets instead of numbers. The initial Set-Stack Alpha is under construction, and they need you to simulate it in order to verify the operation of the prototype.

The computer operates on a single stack of sets, which is initially empty. After each operation, the cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT, and ADD.
PUSH will push the empty set {} on the stack.
DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
UNION will pop the stack twice and then push the union of the two sets on the stack.
INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
ADD will pop the stack twice, add the first set to the second one, and then push the resulting set on the stack.
For illustration purposes, assume that the topmost element of the stack is
A = {{}, {{}}}

and that the next one is
B = {{}, {{{}}}}.

For these sets, we have |A| = 2 and |B| = 2. Then:
UNION would result in the set { {}, {{}}, {{{}}} }. The output is 3.
INTERSECT would result in the set { {} }. The output is 1.
ADD would result in the set { {}, {{{}}}, {{},{{}}} }. The output is 3.

Input

An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each test case contains the number of operations 0 ≤ N ≤ 2 000. Then follow N lines each containing one of the five commands. It is guaranteed that the SetStack computer can execute all the commands in the sequence without ever popping an empty stack.
Output

For each operation specified in the input, there will be one line of output consisting of a single integer. This integer is the cardinality of the topmost element of the stack after the corresponding command has executed. After each test case there will be a line with * (three asterisks).
Sample Input

2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT
Sample Output

0
0
1
0
1
1
2
2
2


0
0
1
0
0


Source

Northwestern Europe 2006

#include<iostream>
#include<map>
#include<vector>
#include<set>
#include<algorithm>
#include<stack>
using  namespace std;

#define ALL(x) x.begin(),x.end()
#define INS(x) inserter(x,x.begin())

typedef set<int> Set;

map<Set,int> IDCache;
vector<Set> SetCache;

int ID(Set s)
{
    if(IDCache.count(s)){
        return IDCache[s];
    }
    SetCache.push_back(s);
    return IDCache[s] = SetCache.size() - 1;
}

int main()
{
    stack<int> s;
    int t;
    cin >> t;
    while(t-- > 0){
        int n;
        cin >> n;
        for(int i = 0; i < n; i++){
            string cmd;
            cin >> cmd;

            if(cmd == "PUSH"){
                s.push(ID(Set()));
            }else if(cmd == "DUP"){
                s.push(s.top());
            }else{
                Set x1 = SetCache[s.top()]; s.pop();
                Set x2 = SetCache[s.top()]; s.pop();
                Set x;

                if(cmd == "UNION"){
                    set_union(ALL(x1),ALL(x2),INS(x));
                    s.push(ID(x));
                }else if(cmd == "INTERSECT"){
                    set_intersection(ALL(x1),ALL(x2),INS(x));
                    s.push(ID(x));
                }else if(cmd == "ADD"){
                    x = x2;
                    x.insert(ID(x1));
                    s.push(ID(x));
                }
            }

            cout << SetCache[s.top()].size() << endl;

        }
        cout << "***" << endl;
    }
}

PS: 可以通过hdoj,在poj上超时。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值