UVA 10943 HOW do you add?

Question;
Larry is very bad at math — he usually uses a calculator, which
worked well throughout college. Unforunately, he is now struck in
a deserted island with his good buddy Ryan after a snowboarding
accident.
They’re now trying to spend some time figuring out some good
problems, and Ryan will eat Larry if he cannot answer, so his fate
is up to you!
It’s a very simple problem — given a number N, how many ways
can K numbers less than N add up to N?
For example, for N = 20 and K = 2, there are 21 ways:
0+20
1+19
2+18
3+17
4+16
5+15

18+2
19+1
20+0
Input
Each line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100,
inclusive. The input will terminate on 2 0’s.
Output
Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K,
print a single number mod 1,000,000 on a single line.
Sample Input
20 2
20 2
0 0
Sample Output
21
21
**提议概述:给你一个数N和K,让你将N拆分为K个数,并让你求出有多少种拆分的方法?
思路:这道题看到的时候,开始感觉挺忙然,但你会发现这道题用dp是不错的选择;
核心:dp[N][K]=dp[i][k-1] (0<=i<=N)**
(http://acm.hust.edu.cn/vjudge/contest/121559#problem/B)

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int dp[105][105];
void inti()
{
    memset(dp,0,sizeof(dp));
    int i,j,k;
    for(i=0;i<105;i++)
        dp[0][i]=1;
    for(k=1;k<105;k++)
    {
        for(j=1;j<105;j++)
        {
            for(i=0;i<=j;i++)
                dp[j][k]=(dp[j][k]+dp[i][k-1])%1000000;
        }

    }
}
int main()
{
    int n,k;
    inti();
    while (~scanf("%d%d",&n,&k))
    {
        if(n==0&&k==0)
            break;
        printf("%d\n",dp[n][k]);
    }
    return 0;
}

体会:遇到此类问题应先考虑dp会使问题变得简便!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值