AtCoder Beginner Contest 069

C - 4-adjacent

Problem Statement

We have a sequence of length Na=(a1,a2,…,aN). Each ai is a positive integer.

Snuke's objective is to permute the element in a so that the following condition is satisfied:

  • For each 1iN1, the product of ai and ai+1 is a multiple of 4.

Determine whether Snuke can achieve his objective.

Constraints

  • 2N105
  • ai is an integer.
  • 1ai109

Input

Input is given from Standard Input in the following format:

N
a1 a2  aN

Output

If Snuke can achieve his objective, print Yes; otherwise, print No.

Sample Input 1

3
1 10 100

Sample Output 1

Yes

One solution is (1,100,10).


Sample Input 2

4
1 2 3 4

Sample Output 2

No

It is impossible to permute a so that the condition is satisfied.


Sample Input 3

3
1 4 1

Sample Output 3

Yes

The condition is already satisfied initially.


Sample Input 4

2
1 1

Sample Output 4

No

Sample Input 5

6
2 7 1 8 2 8

Sample Output 5

Yes
yes的条件:总数的一半要 <= 被4整除数的个数  | |  被4整除数的个数*2+被2整除但不能被4整除数的个数 <= 总数。


#include <iostream>  
#include <cstring>  
#include <algorithm>  
using namespace std;  
int a[100005];  
int main()  
{  
    int n,f=0,i,x=0,y=0;  
    while(cin>>n)  
    {  
        for(i=0;i<n;i++)  
        {  
            cin>>a[i];  
        }     
           for(i=0;i<n;i++)  
            {  
                 if(a[i]%4==0)x++;  
                 if(a[i]%2==0&&a[i]%4!=0)y++;  
                 if(x*2+y>=n||x>=n/2)  
                 f=1;  
            }         
        if(f)cout<<"Yes"<<endl;  
            else cout<<"No"<<endl;  
    }  
    return 0;  
}




  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值