HDU 3696 FZU 2006 -- Farm Game SPFA最长路 2010福州区域赛

 

Farm Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 62768/32768 K (Java/Others)
Total Submission(s): 148 Accepted Submission(s): 65


Problem Description
“Farm Game” is one of the most popular games in online community. In the community each player has a virtual farm. The farmer can decide to plant some kinds of crops like wheat or paddy, and buy the corresponding crop seeds. After they grow up, The farmer can harvest the crops and sell them to gain virtual money. The farmer can plant advanced crops like soybean, watermelon or pumpkin, as well as fruits like lychee or mango.

Feeding animals is also allowed. The farmer can buy chicken, rabbits or cows and feeds them by specific crops or fruits. For example, chicken eat wheat. When the animals grow up, they can also “output” some products. The farmer can collect eggs and milk from hens and cows. They may be sold in a better price than the original crops.

When the farmer gets richer, manufacturing industry can be set up by starting up some machines. For example, Cheese Machine can transfer milk to cheese to get better profits and Textile Machine can spin cony hair to make sweaters. At this time, a production chain appeared in the farm.

Selling the products can get profits. Different products may have different price. After gained some products, the farmer can decide whether to sell them or use them as animal food or machine material to get advanced products with higher price.

Jack is taking part in this online community game and he wants to get as higher profits as possible. His farm has the extremely high level so that he could feed various animals and build several manufacturing lines to convert some products to other products.

In short, some kinds of products can be transformed into other kinds of products. For example, 1 pound of milk can be transformed into 0.5 pound of cheese, and 1 pound of crops can be transformed into 0.1 pound of eggs, etc. Every kind of product has a price. Now Jack tell you the amount of every kind of product he has, and the transform relationship among all kinds of products, please help Jack to figure out how much money he can make at most when he sell out all his products.

Please note that there is a transforming rule: if product A can be transformed into product B directly or indirectly, then product B can never be transformed into product A, no matter directly or indirectly.


Input
The input contains several test cases. The first line of each test case contains an integers N (N<=10000) representing that there are N kinds of products in Jack’s farm. The product categories are numbered for 1 to N. In the following N lines, the ith line contains two real numbers p and w, meaning that the price for the ith kind of product is p per pound and Jack has w pounds of the ith kind of product.

Then there is a line containing an integer M (M<=25000) meaning that the following M lines describes the transform relationship among all kinds of products. Each one of those M lines is in the format below:

K a 0, b 1, a 1, b 2, a 2, …, b k-1, a k-1

K is an integer, and 2×K-1 numbers follows K. ai is an integer representing product category number. bi is a real number meaning that 1 pound of product a i-1 can be transformed into bi pound of product ai.

The total sum of K in all M lines is less than 50000.

The input file is ended by a single line containing an integer 0.


Output
For each test case, print a line with a real number representing the maximum amount of money that Jack can get. The answer should be rounded to 2 digits after decimal point. We guarantee that the answer is less than 10^10.

Sample Input
  
  
2 2.5 10 5 0 1 2 1 0.5 2 2 2.5 10 5 0 1 2 1 0.8 2 0

Sample Output
  
  
25.00 40.00

Source

Recommend
chenyongfu
 
题意:有n种产品,每种产品有一定的价值和数量,
某些产品可以转换为另一种产品,有一定的转换率(转换中数量有损失)。
求最多能获得多少价值。
 
在转换过程中,转换率是要乘起来的,最后再乘上转换成的产品的价值,
如果这个价值比原来的大,就转换产品。
由于可以通过多种路径转换成另一种产品,所以用SPFA求最长路。
乘法通过log取对数转换为加法。
现在需要知道每个产品所能转换得到的最多价值,也就是求每个点到其他点最长路的最大值。
加一个附加点s,所有点连接到s,边权为log(p[i]),这样直接求每个点到s的最长路就可以知道最大值了。
这样需要n次SPFA,不过如果我们把图反向,求一次s开始的最长路,就可以知道所有点能转换的最大价值了。
最后再把这些值和以前的价值比较,得到每种产品的最大价值。
PS:由于是一个有向无环图,所以网上一些代码是DP或者拓扑排序。
 
代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#define N 10005
using namespace std;

int n,m,num,adj[N],q[N];
bool f[N];
double low[N],p[N],w[N];
struct edge
{
    int v,pre;
    double w;
    edge(){}
    edge(int vv,double ww,int p){v=vv;w=ww;pre=p;}
}e[N*5];
void insert(int u,int v,double w)
{
    e[num]=edge(v,w,adj[u]);
    adj[u]=num++;
}
void spfa(int x)
{
    int i,v,head=0,tail=0;
    memset(f,0,sizeof(f));
    memset(low,-0x3f,sizeof(low));
    low[x]=0;
    q[++tail]=x;
    while(head!=tail)
    {
        x=q[head=(head+1)%N];
        f[x]=0;
        for(i=adj[x];~i;i=e[i].pre)
            if(low[v=e[i].v]<low[x]+e[i].w)
            {
                low[v]=low[x]+e[i].w;
                if(!f[v])
                {
                    f[v]=1;
                    q[tail=(tail+1)%N]=v;
                }
            }
    }
}
int main()
{
    while(scanf("%d",&n),n)
    {
        int i,k,a,b;
        double t,ans=0;
        num=0;
        memset(adj,-1,sizeof(adj));
        for(i=1;i<=n;i++)
            scanf("%lf%lf",p+i,w+i);
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d",&k);
            scanf("%d",&a);
            for(i=1;i<k;i++)
            {
                scanf("%lf%d",&t,&b);
                insert(b,a,log(t));
                a=b;
            }
        }
        for(i=1;i<=n;i++)
            insert(0,i,log(p[i]));
        spfa(0);
        for(i=1;i<=n;i++)
        {
            if(p[i]<exp(low[i]))
                p[i]=exp(low[i]);
            ans+=p[i]*w[i];
        }
        printf("%.2f\n",ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值