浙江大学PAT_甲级_1081. Rational Sum (20)

题目链接:点击打开链接

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24
我的C++

#include<iostream>
using namespace std;
long long greatest_common_divisor(long long a, long long b)//求最大公约数
{
	int r;
	while (b>0)
	{
		r = a%b;
		a = b;
		b = r;
	}
	return a;
}
int main()
{
	long long numerator, denominator, divisor;//分子,分母,最大公约数
	long long num_sum=0,den_sum=1;//和的分子,和的分母
	int n;
	cin >> n;
	while (n--)
	{
		scanf("%lld/%lld", &numerator, &denominator);
		num_sum = num_sum*denominator + den_sum*numerator;
		den_sum = den_sum*denominator;
		divisor = greatest_common_divisor(labs(num_sum), labs(den_sum));//最大公约数
		num_sum = num_sum / divisor;//约分
		den_sum = den_sum / divisor;//约分
	}
	if (num_sum == 0)//和等于0
	{
		printf("0");//直接输出
	}
	else//和不为零
	{
		if (num_sum / den_sum&& num_sum%den_sum)//带分数
		{
			cout << num_sum / den_sum<<' '<<num_sum%den_sum<<'/'<<den_sum;
		}
		else if (num_sum / den_sum != 0)//整数
		{
			cout << num_sum / den_sum;
		}
		else if (num_sum%den_sum != 0)//真分数
		{
			cout << num_sum << '/' << den_sum << endl;
		}

	}
	//system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值