POJ 1222 EXTENDED LIGHTS OUT

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.


The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

Note:
1. It does not matter what order the buttons are pressed.
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

题目大意:

给你一个5*6的矩阵,矩阵里每一个单元都有一个灯和一个开关,如果按下此开关,那么开关所在位置的那个灯和开关前后左右的灯的状态都会改变(即由亮到不亮或由不亮到亮)。给你一个初始的灯的状态,问怎样控制每一个开关使得所有的灯最后全部熄灭(此题保证有唯一解)。
输入有多组数据。
第一行一个整数n为数据组数。每组数据有一个5*6的矩阵,由0、1组成,其中1为开,0为关。

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

题解

高斯消元,这题好像是高斯消元“开关问题”的裸题。详细思路可见http://hi.baidu.com/ofeitian/item/9899edce6dc6d3d297445264
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int T,a[10][10],id[10][10],n,b[100][100],ans[100];
int xx[4]={0,0,1,-1}, yy[4]={1,-1,0,0};
void init()
{
	int i,j;
	for(i=0;i<5;i++)
	for(j=0;j<6;j++)
	   {scanf("%d",&a[i][j]);
	    id[i][j]=6*i+j;
	    if(a[i][j]==0) b[id[i][j]][n]=0;
	    else b[id[i][j]][n]=1;
	   }
}
bool check(int x,int y)
{
	if(x<0||y<0||x>=5||y>=6) return false;
	return true; 
}
void gene()
{
	int i,j,k,x,y,xt,yt;
	for(i=0;i<5;i++)
	for(j=0;j<6;j++)
	   {x=id[i][j]; b[x][x]=1;
	    for(k=0;k<4;k++)
	       {xt=i+xx[k]; yt=j+yy[k];
		    if(check(xt,yt))
		       {y=id[xt][yt]; b[x][y]=1;}
		   }
	   }
}
void calcu()
{
	int row=0,col=0,i,j,k,x,y;
	int sum;
	while(row<n&&col<n)
	   {for(i=row,j=-1;i<n;i++)
	       {if(b[i][col])
		       {j=i; break;}
		   }
		if(j!=row)
		   {for(i=col;i<=n;i++)
		       {k=b[row][i];
		        b[row][i]=b[j][i];
		        b[j][i]=k;
		       }
		   }
		x=b[row][col];
		for(i=row+1;i<n;i++)
		   {y=b[i][col];
		    for(j=col;j<=n;j++)
		       b[i][j]=(b[i][j]*x-b[row][j]*y)%2;
		   }
		row++; col++;
	   }
	i=row-1; j=n-1;
	while(i>=0)
	   {sum=0;
		for(k=j+1;k<n;k++)
	       sum=sum+b[i][k]*ans[k];
	    ans[j]=(b[i][n]-sum)/b[i][j];
	    ans[j]=ans[j]%2;
	    i--; j--;
	   }
	for(i=0;i<n;i++) ans[i]=(ans[i]+2)%2;
	for(i=0;i<5;i++)
	for(j=0;j<6;j++)
	   {printf("%d",ans[i*6+j]);
	    if(j==5) printf("\n");
	    else printf(" ");
	   }
}
int main()
{
	scanf("%d",&T); n=30;
	for(int c=1;c<=T;c++)
	   {printf("PUZZLE #%d\n",c);
	    memset(b,0,sizeof(b));
	    init(); gene(); calcu();
	   }
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值