关闭

关于新版ADT创建项目时出现appcompat_v7的问题

59人阅读 评论(0) 收藏 举报
  1. 首先我们打开Eclipse,新建一个Android项目,这里名字就用“test”好了,一路默认next下去,最后“Finish”完成项目的创建。

    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
  2. 2

    你会发现项目创建好后,workspace栏里除了我们创建的“test”项目,还多了一个名为“appcompat_v7”的包,而且这个包显示有错误(红色x号),而“test”包显示一个红色的感叹号。

    关于新版ADT创建项目时出现appcompat_v7的问题
  3. 3

    如果你不习惯appcompat_v7包的自动产生而把这个包删了,那么“test”包就会出现很多错误。那么怎么结决这个这一系列的问题呢?请看下面解决方法。

    关于新版ADT创建项目时出现appcompat_v7的问题
    END

解决方法

  1. 首先解决项目建成后appcompat_v7包出错。test包出现红色警告的问题。

    点击菜单栏"Project",选择"Clean",然后点击"OK",Clean完成后,你会发现appcompat_v7包出错。test包出现红色警告的问题已经解决了,只是test包还有黄色警告,那只是因为test的Java文件中import的类没有被使用,所以完全不用管它。

    如果还不管用,那么右键appcompat_v7包,选择Properties,点"Android",如果Library栏下的"Is Library"方框没勾选,则勾选上,点击"OK",然后再照以上步骤执行"Clean"操作即可。

    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
  2. appcompat_v7包删除后,test项目各种出错,说明test项目是依赖于appcompat_v7包的,所以这个appcompat_v7包是不能被删除的。那么你不用管这个包,直接做你的项目就行了。

  3. 如果你依旧对appcompat_v7包耿耿于怀,我告诉你一个建项目时不出现appcompat_v7包的方法。既然appcompat_v7包是一个能让2.1以上全使用上4.0版本的界面的支持库,那么如图所示,我们建项目时直接把最小SDK选在Android4.0以上不就不需要这个支持库了吗?结果证明我们的想法是对的。

    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题

0
0
查看评论

Eclipse 打包Android时appcompat_v7总报错

Android项目打包(Export Signed Application Package)时appcompat_v7总报如下错误: 将appcompat_v7删除重新导入也报错,单独运行Android项目没问题,也不报错,只是打包时候报错,郁闷中? 其中的...
  • runzhi5172
  • runzhi5172
  • 2017-01-02 12:18
  • 88

关于新版ADT创建项目时出现appcompat_v7的问题

关于新版ADT创建项目时出现appcompat_v7的问题   做Android开发的朋友最近会发现,更新ADT至22.6.0版本之后,创建新的安装项目,会出现appcompat_v7的内容。并且是创建一个新的内容就会出现。这到底是怎么回事呢?原来appcompat_v7...
  • cicilover
  • cicilover
  • 2014-08-19 18:36
  • 394

关于新版ADT(20140321)创建项目时出现appcompat_v7的问题

建项目时不出现appcompat_v7包的方法。既然appcompat_v7包是一个能让2.1以上全使用上4.0版本的界面的支持库,那么如图所示,我们建项目时直接把最小SDK选在Android4.0以上不就不需要这个支持库了吗?结果证明我们的想法是对的。
  • zengtian006
  • zengtian006
  • 2014-04-29 14:25
  • 342

20151125-01 关于新版ADT创建项目时出现appcompat_v7的问题

http://jingyan.baidu.com/article/3ea51489e04eb852e61bbaa4.html 做Android开发的朋友最近会发现,更新ADT至22.6.0版本之后,创建新的安装项目,会出现appcompat_v7的内容。并且是创建一个新的内容就会出现。...
  • zebratoo
  • zebratoo
  • 2015-11-25 23:16
  • 133

新版ADT创建项目时出现appcompat_v7的问题

Android的ADT更新到22.6.0版本之后,每次创建新的工程,会自动出现appcompat_v7的兼容包。 appcompat_v7使2.1以上版本都可以使用4.0版本的界面。 解决方法:1、检查appcompat_v7->"Is Library",工程是...
  • u013670933
  • u013670933
  • 2014-12-23 01:46
  • 485

关于Android新版ADT创建项目时出现appcompat_v7的问题

 做Android开发的朋友最近会发现,更新ADT至22.6.0版本之后,创建新的安装项目,会出现appcompat_v7的内容。并且是创建一个新的内容就会出现。这到底是怎么回事呢?原来appcompat_v7是Google自己的一个兼容包,就是一个支持库,能让2.1以上全使用上4.0版本的界...
  • drl_1989
  • drl_1989
  • 2014-05-07 10:18
  • 1033

ADT创建项目时出现appcompat_v7的问题

做Android开发的朋友最近会发现,更新ADT至22.6.0版本之后,创建新的安装项目,会出现appcompat_v7的内容。并且是创建一个新的内容就会出现。这到底是怎么回事呢?原来appcompat_v7是Google自己的一个兼容包,就是一个支持库,能让2.1以上全使用上4.0版本的界面。通过...
  • u011496272
  • u011496272
  • 2014-11-30 23:36
  • 214

关于新版ADT每次创建项目都出现appcompat_v7的问题

新版ADT(22.6.0版本之后,创建新的安装项目,会出现appcompat_v7的内容。并且是创建一个新的内容就会出现。这到底是怎么回事呢?原来appcompat_v7是Google自己的一个兼容包,就是一个支持库,能让2.1以上全使用上4.0版本的界面。
  • ava_chenlan
  • ava_chenlan
  • 2014-06-18 21:56
  • 1337

新版ADT创建项目或导入项目appcompat_v7问题

导入项目时后,查看项目-》首
  • shiyani2012year
  • shiyani2012year
  • 2014-05-06 16:16
  • 2765

一招解决新版ADT创建项目时出现appcompat_v7并报错

方法一:把Android的workspace文件夹删掉就行了。或者只用 把appcompat_v7文件夹删除,它会在创建项目时重新生成就OK。 方法二:建项目时直接把最小SDK选在Android4.0及以上就可以。 更新ADT至22.6.0版本之后,创建新的安装项目,会出现...
  • chenhao0568
  • chenhao0568
  • 2015-11-08 11:49
  • 364
    个人资料
    • 访问:780次
    • 积分:26
    • 等级:
    • 排名:千里之外
    • 原创:0篇
    • 转载:10篇
    • 译文:0篇
    • 评论:0条
    文章分类
    文章存档