HDU 1073 Online Judge

Online Judge

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6186 Accepted Submission(s): 2318

Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user’s result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return “Accepted”, else if the only differences between the two files are spaces(’ ‘), tabs(‘\t’), or enters(‘\n’), the Judge System should return “Presentation Error”, else the system will return “Wrong Answer”.

Given the data of correct output file and the data of user’s result file, your task is to determine which result the Judge System will return.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user’s result file. Both of them are starts with a single line contains a string “START” and end with a single line contains a string “END”, these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.

Output
For each test cases, you should output the the result Judge System should return.

Sample Input
4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3

END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1 + 2 = 3
END

Sample Output
Presentation Error
Presentation Error
Wrong Answer
Presentation Error

Author
Ignatius.L

题目大意,给你输出和答案啊,问你错误类型

思路 字符串处理

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

char s1[5050],s2[5050],c,s3[5050],s4[5050],s[5050];
char q1[10]={"START"},q2[10]={"END"};///判断是否开始输入和结束

int main()
{
    int l1,l2,t,i,j;
    cin>>t;
    while(t--)
    {
        memset(s1,0,sizeof(s1));
        memset(s2,0,sizeof(s2));
        memset(s3,0,sizeof(s3));
        memset(s4,0,sizeof(s4));
        while(cin>>s&&strcmp(s,q1));
        while(1){
            memset(s,0,sizeof(s));
            gets(s);
            if(strcmp(s,q2)==0){
                break;
            }
            if(strlen(s))
                strcat(s1,s);
            else
                strcat(s1,"\n");
        }
        while(cin>>s&&strcmp(s,q1));
        while(1){
            memset(s,0,sizeof(s));
            gets(s);
            if(strcmp(s,q2)==0){
                break;
            }
            if(strlen(s))
                strcat(s2,s);
            else
                strcat(s2,"\n");
        }
        l1=strlen(s1);
        l2=strlen(s2);
        if(strcmp(s1,s2)==0){
            cout<<"Accepted"<<endl;
            continue;
        }
        for(i=0,j=0;i<l1;i++){
            if(s1[i]!=' '&&s1[i]!='\t'&&s1[i]!='\n')
                s3[j++]=s1[i];
        }
        for(i=0,j=0;i<l2;i++){
            if(s2[i]!=' '&&s2[i]!='\t'&&s2[i]!='\n')
                s4[j++]=s2[i];
        }
        if(strcmp(s3,s4))
            cout<<"Wrong Answer"<<endl;
        else
            cout<<"Presentation Error"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值