关闭

maven项目jar包版本错误:'dependencies.dependency.version' for xxx:jar is missing. @ line xx, column xx

1514人阅读 评论(0) 收藏 举报
分类:
[ERROR]   The project XXX (/home/×××/pom.xml) has 1 error
[ERROR]     'dependencies.dependency.version' for xxx:jar is missing. @ line xx, column xx
maven项目中
父项目的pom.xml通过
    <modules>
        <module>XXX</module>
      </modules>
将子项目载入
子项目中的pom.xml通过
  <parent>
        <artifactId>YYY</artifactId>
        <groupId>com.ZZZ</groupId>
        <version>1.0.0</version>
    </parent>
配置父项目
那么可以只在父项目的pom.xml定义所需依赖的jar包的版本即可,子项目只需要简单引用
但是尝试多次,子项目加载时总是报如上缺少jar包版本信息的错误

折腾了很久发现是在设置父项目的依赖jar包时外层少加了这个依赖版本管理的标签<dependencyManagement>


<dependencyManagement>
    <dependencies>

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:68366次
    • 积分:1729
    • 等级:
    • 排名:千里之外
    • 原创:98篇
    • 转载:75篇
    • 译文:1篇
    • 评论:0条
    文章分类