杭电oj 5813 Elegant Construction

Problem Description

Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it’s your showtime!

Input

The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.

Output

For each test case, output “Case #X: Y” in a line (without quotes), where X is the case number starting from 1, and Y is “Yes” if you can construct successfully or “No” if it’s impossible to reach the requirements.

If Y is “Yes”, output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.

Sample Input

3
3
2 1 0
2
1 1
4
3 1 1 0

Sample Output

Case #1: Yes
2
1 2
2 3
Case #2: No
Case #3: Yes
4
1 2
1 3
2 4
3 4

题意:

要求构造一个有向图,使得点i能够恰好到达Ai个点.(直接间接皆可)
输出任意满足条件的图即可,没有要求最小.

官方题解:
将顶点按能到达的点数从小到大排序,排好序之后每个点只能往前面的点连边. 因而如果存在一个排在第i位的点,要求到达的点数大于i-1,则不可行;否则就可以按照上述方法构造出图. 复杂度O(N^2).
以下附上代码:

#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <iostream>
#include <string.h>
using namespace std;
struct node
{
    int id;
    int val;
} a[1002];
int ans[1000002][2];
int cmp(node a,node b)
{
    return a.val<b.val;
}
int main()
{
    int t,tt=1,i,j;
    scanf("%d",&t);
    while(t--)
    {
        int n,flag=0,k=0;
        scanf("%d",&n);
        ans[1000002][2]= {0};
        printf("Case #%d: ",tt++);
        for(i=0; i<n; i++)
        {
            scanf("%d",&a[i].val);
            a[i].id=i+1;
        }
        sort(a,a+n,cmp);
        for(i=n-1; i>=0; i--)
        {
            int t1=0;
            for(j=0; j<n; j++)
            {
                if(a[i].val>a[j].val)
                {
                    ans[k][0]=a[i].id;
                    ans[k][1]=a[j].id;
                    t1++;
                    k++;

                }
                if(t1==a[i].val)
                    break;
            }
            if(t1==a[i].val)
                continue;
            else
                flag=1;
        }
        if(flag==1)
        {
            printf("No\n");
            continue;
        }
        else
        {
            printf("Yes\n");
            printf("%d\n",k);
            for(i=0; i<k; i++)
                printf("%d %d\n",ans[i][0],ans[i][1]);
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值