Eclipse新建Android项目后,出现“The import android.support.v7.app cannot be resolved”

原创 2015年04月24日 20:42:47

4种办法:

1、项目右键属性---》android----》》配置sdk, add 选择一个 library project (添加一个库项目)

2、项目右键---》》 路径配置----》library里面检查 是否有多余 (missing),,此时往往在项目是警告的小黄色图标提示。 remove掉

3、看看是否有support-v4 冲突了,如果本项目和应用的项目里面有v4 冲突的情况,要进行统一,成一个版本,并将本项目lib里的包右键,添加配置路径。

4、如果出现java文件的里的错误提示: “The import android.support.v7.app cannot be resolved”

先看看是否引入了该包,是否把包的文件添加到了路径里面,如果还不行:::


1》在Eclipse中新建Android项目后,出现“The import android.support.v7.app cannot be resolved

如下图所示:


意思为“无法解析引入的android.support.v7.app”

2>解决方法,如下:

2.1》选中项目--》右键--》Properties,打开如下:



2.2》按上图中1,2,3操作,打开如下:


按图中1,2操作。然后返到2.1中图,点击“OK”

2.3》"Clean "一下项目,再“Rebuild”一下项目就OK 了。


批量解决Api 最小版本要求的方法

在我们编程的过程中会出现     Call requires API level 9 (current min is 1)  ,这个问题有时会在我们既是在build.gradle中设置了最小sdk和t...

The import android.support.v7.app cannot be resolved的解决方法

当导入一个新项目时,有时会提示错误,其中一种错误是The import android.support.v7.app cannot be resolved,经常遇到,自己做个总结: 对准项目,点击右键...

关于The import android.support.v7.app cannot be resolved

不想说什么,lib包下面是v4包,然后又在properties的Android页面导入了v7支持包,两个包冲突了 删除v4包即可...

The import android.support.v7.app cannot be resolved(安卓Eclipse问题 )

今天打开eclipse,遇到了这个问题 The import android.support.v7 cannot be resolved。

import android.support.v7.app.ActionBarActivity; 报错问题

问题是这样的: 昨天在加里练习写了一个简单的adnroid apk, 提交到github。 其实当时 我就很奇怪, 我只是写了一个project, 为什么eclipse上有两个project。 如图:...
  • smallmao
  • smallmao
  • 2015年04月14日 14:13
  • 32459

Eclipse开发andriod程序时import android.support.v4或者import android.support.v7提示导入错误解决办法

在使用Eclipse开发andriod程序时,程序中提示import android.support.v4.XXX或者import android.support.v7.XXX提示导入错误解决办法...

The import android.support.v7.app cannot be resolved的解决方法

当导入一个新项目时,有时会提示错误,其中一种错误是The import android.support.v7.app cannot be resolved,经常遇到,自己做个总结: 对准项目,点击右键...

【Android】切换Activity时使用Bundle封装Map对象

Android默认是不能在Bundle里传递Map对象,所以需要将Map对象序列化。首先构造一个SerializableMap类:public class SerializableMap implem...

The import android.support.v4 cannot be resolved 问题解决方法

1.The import android.support.v4 cannot be resolved 问题解决方法 2.Android Call requires API level 11 ...

Cocos2d-x 3.2导入到Eclipse后出现The import org.cocos2dx.lib cannot be resolved错误

转载自:http://blog.csdn.net/cleopard/article/details/38538055 Cocos2d-x 3.2导入到Eclipse后出现The import ...
  • CDAmber
  • CDAmber
  • 2015年01月11日 22:41
  • 1619
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Eclipse新建Android项目后,出现“The import android.support.v7.app cannot be resolved”
举报原因:
原因补充:

(最多只允许输入30个字)