LightOJ 1282

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

这是一道快速幂的题,后面的位数只要学过快速幂和mod运算的都能很快求解,尽管里边有坑,就是在mod出来后的数如果小于3位要在前面补上0,这也是我在自己打出数据后才测试出来需要前导0的,害我wa了好多次。再者就是前三位的求解了,这是一位dalao的解题方法,我只是照搬了,然后ac而已,其实也不难,就是将一个数变成只有个位的浮点数,然后快速幂,最后把这个数乘以100就行了,例如:123456,那么就转化为1.23456,然后乘一个就又转化一次,最后再将这个数乘以100截断就可以了。

具体实现如下:

#include <stdio.h>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#define INF 1e9

using namespace std;
//FILE *fp;
int t,n,k;
int main(void)
{
    //fp = fopen("1234.txt","r");
    scanf("%d",&t);
    int count1 = 1;
    while(t--)
    {
        scanf("%d %d",&n,&k);
        long long int ans1 = 1,bis = n%1000,ans2 = 1,k1=k;
        while (k1!=0)
        {
            if(k1&1)
            {
                ans1*=bis;
                ans1%=1000;
            }
            bis*=bis;
            bis%=1000;
            k1>>=1;
        }
        double nn = n,ans3=1.0;
        while (nn>=1)
        {
            nn/=10;
        }
        nn*=10.0;
        //cout<<nn<<endl;
        while (k!=0)
        {
            if(k&1)
            {
                ans3*=nn;
                while (ans3>=1)
                {
                    ans3/=10.0;
                }
                ans3*=10.0;
            }
            nn*=nn;
            while (nn>=1)
            {
                nn/=10.0;
            }
            nn*=10.0;
            k>>=1;
        }
        ans2 = ans3*100;
        printf("Case %d: ",count1++);
        cout<<ans2<<" ";
        printf("%03d\n",ans1);
    }
    return 0;
}
注意前导0,今天惨败,不行,要加把劲。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值