HDU 5001 Walk (概率DP)

传送门

Walk

Time Limit: 30000/15000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 996 Accepted Submission(s): 634
Special Judge

Problem Description
I used to think I could be anything, but now I know that I couldn’t do anything. So I started traveling.

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn’t contain it.

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b.

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.

Output
For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.

Your answer will be accepted if its absolute error doesn’t exceed 1e-5.

Sample Input
2
5 10 100
1 2
2 3
3 4
4 5
1 5
2 4
3 5
2 5
1 4
1 3
10 10 10
1 2
2 3
3 4
4 5
5 6
6 7
7 8
8 9
9 10
4 9

Sample Output
0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.6993317967
0.5864284952
0.4440860821
0.2275896991
0.4294074591
0.4851048742
0.4896018842
0.4525044250
0.3406567483
0.6421630037

Source
2014 ACM/ICPC Asia Regional Anshan Online

题目大意:
首先给出 n 个点,m 条边,然后给定一个走的步数 step,一个人在图的点之间(有边的)行走,从每一点开始走的概率相同,从每一个点走向它相邻点的每一个点的概率都是相等的.让你求的就是不经过 i(1<= i <=n) 点的概率

解题思路:
当时我一看题目,就瞄了几眼,我一瞅这不是个图的问题吗,ka就交给队友,然后队友又一看不是呀/汗,是一个关于概率的问题,我说那我再看看。果然是一个概率的题目,我们可以设DP[i][j]表示的是走 i 步到达 j 点的概率,其实DP主要就是写一个状态转移方程那么概率DP当然也是了
我们可以这么想DP[i][j]怎么来的呢,肯定是走i-1步到的呀,那么走到i-1步的时候那么肯定走的就是与 j 点相邻的那个点(也就是有边的点)所以走i步到j点的概率就是
概率就是当前的DP[i-1][vec[k][l]]/vec[k].size(),其中vector数组存的就是当前这个点有几条边,并且保存下来

DP[i][j]+=DP[i1][vec[k][l]]/vec[k].size()

我们要求的是不到i点的概率那么我们抛去i点,那么不到i点的概率就是
DP[step][j] (j!=i)。
My Code:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>

using namespace std;
const int MAXN_N = 55;
const int MAXN_Step = 10005;
vector <int> vec[MAXN_N];
double dp[MAXN_Step][MAXN_N];
int main()
{
    int T, m, n, step;
    cin>>T;
    while(T--)
    {
        cin>>n>>m>>step;
        for(int i=0; i<MAXN_N; i++)
            vec[i].clear();
        int u, v;
        for(int i=0; i<m; i++)
        {
            cin>>u>>v;
            vec[u].push_back(v);
            vec[v].push_back(u);
        }
        for(int i=1; i<=n; i++)
            dp[0][i] = 1.0/n;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=step; j++)
            {
                for(int k=1; k<=n; k++)
                {
                    if(i == k)
                        continue;
                    dp[j][k] = 0;
                    for(int l=0; l<vec[k].size(); l++)
                    {
                        if(vec[k][l] != i)
                            dp[j][k] += dp[j-1][vec[k][l]]*(1.0/vec[k].size());

                    }
                }
            }
            double ans = 0;
            for(int j=1; j<=n; j++)
            {
                if(j != i)
                    ans += dp[step][j];
            }
            printf("%.6lf\n",ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值