HDU 4791 Alice's Print Service(二分)——2013 Asia Changsha Regional Contest

传送门

Alice’s Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2121    Accepted Submission(s): 551


Problem Description
Alice is providing print service, while the pricing doesn’t seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It’s easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , …, s n, p n (0=s 1 < s 2 < … < s n ≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ … ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 .. q m (0 ≤ q i ≤ 10 9 ) are the queries.
 

Output
For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.
 

Sample Input
  
  
1
2 3
0 20 100 10
0 99 100
 

Sample Output
  
  
0
1000
1000

题目大意:

一个人提供打印服务,但是现在打印的服务有一些漏洞,比如说:当打印不到 100 页的价格是每页 20 美分,但当打印不少于 100 页时,

你只需要支付每页只有 10 美分,但是当你想打 99 张的时候,如果打印不到 100 的话就会有点亏,所以最好的打印选择是打印一个额外

的空白页,现在给你的是 T 组数据,每组数据包括两个整数 n m , 表示有 s1 p1 s2  p2 ... sn pn 表示的是打印区间

sisi+1 需要花费 pi 美分钱。然后给了你 m 个询问,每次询问输入一个整数 k, 就是让你求打印 k 张纸的总费用最少是多少?

解题思路:

首先将每个最小的值算出来,就是打印 si 张纸需要的最小代价,然后二分做就行了。

My Code:

/**
2016 - 09 - 23 晚上
Author: ITAK

Motto:

今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
**/

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
const LL INF = 1e17+5;
const int MAXN = 1e6+5;
const int MOD = 1e9+7;
const double eps = 1e-7;
const double PI = acos(-1);
using namespace std;
LL tmp[MAXN], s[MAXN], p[MAXN];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n, m;
        scanf("%d%d",&n,&m);
        memset(p, 0, sizeof(p));
        memset(s, 0, sizeof(s));
        memset(tmp, 0, sizeof(tmp));
        for(int i=0; i<n; i++)
            scanf("%I64d%I64d",&s[i],&p[i]);
        tmp[n] = INF;
        for(int i=n-1; i>=0; i--)
            tmp[i] = min(tmp[i+1], s[i]*p[i]);
        while(m--)
        {
            LL x, ans = 0;
            scanf("%I64d",&x);
            int mid = lower_bound(s, s+n, x) - s;
            if(mid == 0)
            {
                puts("0");
                continue;
            }
            if(s[mid] != x)
                ans = min(tmp[mid], x*p[mid-1]);
            else
                ans = min(tmp[mid], x*p[mid]);
            printf("%I64d\n",ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值