HDU 5907 Find Q(水) —— BestCoder Round #88

传送门

Find Q

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 319    Accepted Submission(s): 181


Problem Description
Byteasar is addicted to the English letter ‘q’. Now he comes across a string S consisting of lowercase English letters.

He wants to find all the continous substrings of S, which only contain the letter ‘q’. But this string is really really long, so could you please write a program to help him?
 

Input
The first line of the input contains an integer T(1T10) , denoting the number of test cases.

In each test case, there is a string S , it is guaranteed that S only contains lowercase letters and the length of S is no more than 100000.
 

Output
For each test case, print a line with an integer, denoting the number of continous substrings of S , which only contain the letter ‘q’.
 

Sample Input
2
qoder
quailtyqqq
 

Sample Output
1
7
 

Source

问题描述
Byteasar迷恋上了'q'这个字母。

在他眼前有一个小写字母组成的字符串$S$,他想找出$S$的所有仅包含字母'q'的连续子串。但是这个字符串实在是太长了,你能写个程序帮助他吗?
输入描述
输入的第一行包含一个正整数$T(1\leq T\leq10)$,表示测试数据的组数。

对于每组数据,包含一行一个小写字母组成字符串$S$,保证$S$的长度不超过$100000$。
输出描述
对于每组数据,输出一行一个整数,即仅包含字母'q'的连续子串的个数。

解题思路:

首先用一个数组 num[i] 记录表示的是连续 i 个字母为 q 的字串的个数,通过规律得到 num[i] = num[i1] + i , 得到了之后我们就直接判断有几个连续的 q 就行了,然后统计答案。

My Code

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>

using namespace std;

typedef long long LL;
const LL MAXN = 1e5+5;
LL ans[MAXN];
char str[MAXN];
void Init(){
    memset(ans, 0, sizeof(ans));
    ans[1] = 1;
    for(LL i=1; i<MAXN; i++)
        ans[i] = ans[i-1] + i;
}
int main()
{
    Init();
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%s",str);
        LL len = strlen(str);
        LL sum = 0;
        LL ans1 = 0;
        for(LL i=0; i<len; i++){
            if(str[i] == 'q')
                sum++;
            else{
                ans1 += ans[sum];
                sum = 0;
            }
        }
        ans1 += ans[sum];
        cout<<ans1<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值