HDU 4569 Special equations(思维)——2013 ACM-ICPC长沙赛区全国邀请赛

227 篇文章 0 订阅
97 篇文章 0 订阅
  Let f(x) = a nx n +…+ a 1x +a 0, in which a i (0 <= i <= n) are all known integers. We call f(x) 0 (mod m) congruence equation. If m is a composite, we can factor m into powers of primes and solve every such single equation after which we merge them using the Chinese Reminder Theorem. In this problem, you are asked to solve a much simpler version of such equations, with m to be prime’s square.
 

Input
  The first line is the number of equations T, T<=50.
  Then comes T lines, each line starts with an integer deg (1<=deg<=4), meaning that f(x)’s degree is deg. Then follows deg integers, representing a n to a 0 (0 < abs(a n) <= 100; abs(a i) <= 10000 when deg >= 3, otherwise abs(a i) <= 100000000, i<n). The last integer is prime pri (pri<=10000).
  Remember, your task is to solve f(x) 0 (mod pri*pri)
 

Output
  For each equation f(x) 0 (mod pri*pri), first output the case number, then output anyone of x if there are many x fitting the equation, else output "No solution!"
 

Sample Input
  
  
4 2 1 1 -5 7 1 5 -2995 9929 2 1 -96255532 8930 9811 4 14 5458 7754 4946 -2210 9601
 

Sample Output
  
  
Case #1: No solution! Case #2: 599 Case #3: 96255626 Case #4: No solution!

题目大意:
有一个多项式 f(x)=anxn+an1xn1+...+a1x+a0 ,让你求的是 f(x)%m==0 的解。
给出一个 T , 表示有 T 组数据,每组数据首先给出一个 n ,然后有 n+1 个数,从左往右分别表示 an,an1...a1,a0 , 然后给出一个数 m ,求 f(x)%m2==0 的解,如果解有多个输出任意一个,否则输出 No solution!

解题思路:
因为 f(x)%m2==0 ,就一定满足 f(x)%m==0 ,那么我们就把 i 0 遍历到 m1 ,因为在往后计算的话就是重复了,循环节就是 m ,这个地方需要好好理解一下,当我们找到这样的数之后在对其判断 f(i)%m2 是不是等于 0 ,如果等于 0,那么我们就找到解了,然后输出,否则的话,我们将 i+=m( i  m ) ,直到 im2 (如同上一个一样,这里的循环节就是 m2 ),将多项式乘加起来然后计算 f(i)%m2 就OK了,如果直到 im2 还没有找到解的话,那么就是无解,输出 No solution!
代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
typedef long long LL;
LL Pow(LL a, LL b, LL MOD){
    LL ans = 1;
    while(b){
        if(b & 1) ans = (ans*a) % MOD;
        b>>=1;
        a = (a*a) % MOD;
    }
    return ans;
}
LL a[5];
int main()
{
    int T, n;
    scanf("%d",&T);
    for(int cas=1; cas<=T; cas++){
        LL MOD;
        scanf("%d", &n);
        for(int i=n; i>=0; i--) scanf("%lld",&a[i]);
        scanf("%lld",&MOD);
        printf("Case #%d: ",cas);
        LL mm = MOD*MOD;
        for(LL i=0; i<MOD; i++){
            LL sum = 0;
            for(int j=0; j<=n; j++)
                sum = (sum + a[j]*Pow(i, j, MOD))%MOD;
            if(sum % MOD == 0){
                LL jj = i;
                while(jj < mm){
                    sum = 0;
                    for(int j=0; j<=n; j++)
                        sum = (sum + a[j]*Pow(jj, j, mm))%mm;
                    if(sum == 0){
                        printf("%lld\n",jj);
                        goto endW;
                    }
                    jj += MOD;
                }
            }
        }
        puts("No solution!");
        endW:;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值