hdu 1560 DNA sequence(IDA*)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1560

DNA sequence

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1505    Accepted Submission(s): 730


Problem Description
The twenty-first century is a biology-technology developing century. We know that a gene is made of DNA. The nucleotide bases from which DNA is built are A(adenine), C(cytosine), G(guanine), and T(thymine). Finding the longest common subsequence between DNA/Protein sequences is one of the basic problems in modern computational molecular biology. But this problem is a little different. Given several DNA sequences, you are asked to make a shortest sequence from them so that each of the given sequence is the subsequence of it.

For example, given "ACGT","ATGC","CGTT" and "CAGT", you can make a sequence in the following way. It is the shortest but may be not the only one.

 

Input
The first line is the test case number t. Then t test cases follow. In each case, the first line is an integer n ( 1<=n<=8 ) represents number of the DNA sequences. The following k lines contain the k sequences, one per line. Assuming that the length of any sequence is between 1 and 5.
 

Output
For each test case, print a line containing the length of the shortest sequence that can be made from these sequences.
 

Sample Input
  
  
1 4 ACGT ATGC CGTT CAGT
 

Sample Output
  
  
8
 

Author
LL
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:   1667  1043  1813  1226  1401 

题目大意:给n个序列,找到一个包含所有给出序列的最短长度并输出。
解题思路:采用gei_h()得到当前状态下最长的未匹配的长度。在进行深度搜索。每个串的长度不超过5,最多只有8个序列,所以IDA不超过40次。

详见代码。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

int n;
char ch[10][10];
int len[10],want;
char dir[10]= {'A','C','G','T'};
int wei[10];//记录第i个序列正在使用第几个位置

int get_h()
{
    int t=0;
    for (int i=1; i<=n; i++)
    {
        t=max(t,len[i]-wei[i]);//得到当前情况下最长的未被匹配的长度
    }
    return t;
}

int IDA(int dep)
{
    if(dep+get_h()>want)//当前长度+估测的长度比我想要的还大的话,就不必继续搜索
    {//cout<<get_h()<<endl;
        return 0;}
    if(dep==want)
        return 1;
    int tmp[10];
    for (int i=0; i<4; i++)
    {
        int flag=0;
        memcpy(tmp,wei,sizeof(wei));//先存一下
        for (int j=1; j<=n; j++)
        {
            if (ch[j][wei[j]]==dir[i])//当前的这一位符合
            {
                flag=1;//标记当前状态可以
                wei[j]++;
            }
        }
        if (flag)
        {
            if(IDA(dep+1))//如果可以就继续搜索
                return 1;
            memcpy(wei,tmp,sizeof(tmp));//还原回来
        }
    }
    return 0;
}

int main()
{
    int T;
    scanf("%d",&T);
    while (T--)
    {
        int Max=0;
        scanf("%d",&n);
        for (int i=1; i<=n; i++)
        {
            scanf("%s",ch[i]);
            len[i]=strlen(ch[i]);
            if (len[i]>Max)
                Max=len[i];
        }
        memset(wei,0,sizeof(wei));
        want=Max;//从最长序列开始查找
        while (1)
        {
            if (IDA(0))
            {
                break;
            }
            want++;
        }
        printf ("%d\n",want);
    }
    return 0;
}




 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值