hdu 5777 domino(BestCoder Round #85——思维题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5777

domino

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 678    Accepted Submission(s): 347


Problem Description
Little White plays a game.There are n pieces of dominoes on the table in a row. He can choose a domino which hasn't fall down for at most k times, let it fall to the left or right. When a domino is toppled, it will knock down the erect domino. On the assumption that all of the tiles are fallen in the end, he can set the height of all dominoes, but he wants to minimize the sum of all dominoes height. The height of every domino is an integer and at least 1.
 

Input
The first line of input is an integer T (  1T10 )
There are two lines of each test case.
The first line has two integer n and k, respectively domino number and the number of opportunities.(  2k,n100000 )
The second line has n - 1 integers, the distance of adjacent domino d,  1d100000
 

Output
For each testcase, output of a line, the smallest sum of all dominoes height
 

Sample Input
  
  
1 4 2 2 3 4
 

Sample Output
  
  
9
 

Source
 

题目大意:

小白在玩一个游戏。桌子上有n张多米诺骨牌排成一列。它有k次机会,每次可以选一个还没有倒的骨牌,向左或者向右推倒。每个骨
牌倒下的时候,若碰到了未倒下的骨牌,可以把它推倒。小白现在可以随意设置骨牌的高度,但是骨牌高度为整数,且至少为1,并且
小白希望在能够推倒所有骨牌的前提下,使所有骨牌高度的和最小。
解题思路:

刚开始想着给他分成k个部分,在这部分中肯定是一次推完的,所以长度就固定了,固定成每一段距离+1即可。

按照这个想法继续推一下会发现,既然分成每一部分的时候都要加,那我在最开始的时候求一个和,加上n,再减去前k大的距离即可。因为我从最大距离的地方断开了,分成两次推,所以省掉了一部分高度。

特别注意:

1、推得次数可能大于骨牌数量

2、数据类型要用long long


详见代码。

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;
#define ll long long

ll d[100000+10];

bool cmp(ll a,ll b)
{
    return a>b;
}

int main()
{
    int t;
    ll sum;
    scanf("%d",&t);
    while (t--)
    {
        int n,k;
        sum=0;
        scanf("%d%d",&n,&k);
        for (int i=0; i<n-1; i++)
        {
            scanf("%lld",&d[i]);
            //a[i]=d[i];
            sum+=d[i];
        }
        if (n<=k)
        {
            printf ("%d\n",n);
            continue;
        }
        sum=sum+n;
        sort(d,d+n-1,cmp);

        for (int i=0; i<k-1; i++)
        {
            sum-=d[i];
        }
        printf ("%lld\n",sum);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值