关闭

android 导入gradle项目The project is using an unsupported version of Gradle.

标签: gradleandroid
1051人阅读 评论(0) 收藏 举报
分类:

参考:http://stackoverflow.com/questions/22252956/Android-studio-gradle-issue-upgrading-to-version-0-5-0-gradle-migrating-from-0


com.android.tools.build:gradle:0.6.+          ->           gradle 1.8
com.android.tools.build:gradle:0.7.+          ->           gradle 1.9
com.android.tools.build:gradle:0.8.+          ->           gradle 1.9/1.10
com.android.tools.build:gradle:0.9.+          ->           gradle 1.10/1.11
com.android.tools.build:gradle:0.10.+         ->           gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.11.+         ->           gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.12.+         ->           gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.13.+         ->           gradle 2.1
com.android.tools.build:gradle:0.14.+         ->           gradle 2.1
com.android.tools.build:gradle:1.0.+          ->           gradle 2.2.1-2.3
com.android.tools.build:gradle:1.1.+          ->           gradle 2.2.1-2.3
com.android.tools.build:gradle:1.2.+          ->           gradle 2.2.1+
com.android.tools.build:gradle:1.3.+          ->           gradle 2.2.1+
com.android.tools.build:gradle:1.3.+          ->           gradle 2.2.1+
com.android.tools.build:gradle:1.5.+          ->           gradle 2.2.1+
com.android.tools.build:gradle:2.0.+          ->           gradle 2.10.0+

Android Studio 0.3.x                  ->     gradle-plugin 0.6
Android Studio 0.4.x                  ->     gradle-plugin 0.7
Android Studio 0.4.3+                 ->     gradle-plugin 0.8
Android Studio 0.5.x                  ->     gradle-plugin 0.9
Android Studio 0.5.8                  ->     gradle-plugin 0.9.+ or 0.10.+
Android Studio 0.5.9                  ->     gradle-plugin 0.9.+ or 0.10.4+
Android Studio 0.6.x                  ->     gradle-plugin 0.11.+
Android Studio 0.8.x                  ->     gradle-plugin 0.12.+
Android Studio 0.8.11+                ->     gradle-plugin 0.13.+ / gradle-plugin 0.12.+
Android Studio 0.9.x                  ->     gradle-plugin 0.14.+
Android Studio 1.0.0                  ->     gradle-plugin 1.0.0
Android Studio 1.1.x                  ->     gradle-plugin 1.0.0/ 1.1.x / 1.2.x
Android Studio 1.2.x                  ->     gradle-plugin 1.0.0/ 1.1.x / 1.2.x
Android Studio 1.3.x                  ->     gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x 
Android Studio 1.4.x                  ->     gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x 
Android Studio 1.5.x                  ->     gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x / 1.5.x
Android Studio 2.0.x                  ->     gradle-plugin 2.0.0

 Also gradle 1.12 requires Android Studio 0.5.8+

gradle-wrapper.properties:

distributionUrl=https\://services.gradle.org/distributions/gradle-2.2.1-all.zip


build.gradle:

dependencies {
    classpath 'com.android.tools.build:gradle:1.5.+'
}

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:2522次
    • 积分:80
    • 等级:
    • 排名:千里之外
    • 原创:5篇
    • 转载:4篇
    • 译文:0篇
    • 评论:0条
    文章分类
    文章存档