android 导入gradle项目The project is using an unsupported version of Gradle.

原创 2016年05月30日 10:04:10

参考:http://stackoverflow.com/questions/22252956/Android-studio-gradle-issue-upgrading-to-version-0-5-0-gradle-migrating-from-0


com.android.tools.build:gradle:0.6.+          ->           gradle 1.8
com.android.tools.build:gradle:0.7.+          ->           gradle 1.9
com.android.tools.build:gradle:0.8.+          ->           gradle 1.9/1.10
com.android.tools.build:gradle:0.9.+          ->           gradle 1.10/1.11
com.android.tools.build:gradle:0.10.+         ->           gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.11.+         ->           gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.12.+         ->           gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.13.+         ->           gradle 2.1
com.android.tools.build:gradle:0.14.+         ->           gradle 2.1
com.android.tools.build:gradle:1.0.+          ->           gradle 2.2.1-2.3
com.android.tools.build:gradle:1.1.+          ->           gradle 2.2.1-2.3
com.android.tools.build:gradle:1.2.+          ->           gradle 2.2.1+
com.android.tools.build:gradle:1.3.+          ->           gradle 2.2.1+
com.android.tools.build:gradle:1.3.+          ->           gradle 2.2.1+
com.android.tools.build:gradle:1.5.+          ->           gradle 2.2.1+
com.android.tools.build:gradle:2.0.+          ->           gradle 2.10.0+

Android Studio 0.3.x                  ->     gradle-plugin 0.6
Android Studio 0.4.x                  ->     gradle-plugin 0.7
Android Studio 0.4.3+                 ->     gradle-plugin 0.8
Android Studio 0.5.x                  ->     gradle-plugin 0.9
Android Studio 0.5.8                  ->     gradle-plugin 0.9.+ or 0.10.+
Android Studio 0.5.9                  ->     gradle-plugin 0.9.+ or 0.10.4+
Android Studio 0.6.x                  ->     gradle-plugin 0.11.+
Android Studio 0.8.x                  ->     gradle-plugin 0.12.+
Android Studio 0.8.11+                ->     gradle-plugin 0.13.+ / gradle-plugin 0.12.+
Android Studio 0.9.x                  ->     gradle-plugin 0.14.+
Android Studio 1.0.0                  ->     gradle-plugin 1.0.0
Android Studio 1.1.x                  ->     gradle-plugin 1.0.0/ 1.1.x / 1.2.x
Android Studio 1.2.x                  ->     gradle-plugin 1.0.0/ 1.1.x / 1.2.x
Android Studio 1.3.x                  ->     gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x 
Android Studio 1.4.x                  ->     gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x 
Android Studio 1.5.x                  ->     gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x / 1.5.x
Android Studio 2.0.x                  ->     gradle-plugin 2.0.0

 Also gradle 1.12 requires Android Studio 0.5.8+

gradle-wrapper.properties:

distributionUrl=https\://services.gradle.org/distributions/gradle-2.2.1-all.zip


build.gradle:

dependencies {
    classpath 'com.android.tools.build:gradle:1.5.+'
}

The project is using an unsupported version of the Android Gradle plug-in

如何将Eclipse项目转化成Android Studio项目的方式我就不多说了,但这种转化方式不会百分百成功,多少都会遇到一些问题。 您是否也遇到如下问题呢?报错Error:The project...
  • kingroc
  • kingroc
  • 2016年03月08日 16:04
  • 2279

may be using a version of Gradle that does not contain the method.

转载自:http://www.bubuko.com/infodetail-650124.html The project ‘HackerTool’ may be using a version of...
  • dxy978608510
  • dxy978608510
  • 2016年02月16日 10:16
  • 1464

Gradle DSL method not found: 'useLibrary()' 问题解决方法

问题描述: Error:(31, 0) Gradle DSL method not found: ‘useLibrary()’ Possible causes:The project ‘Hello...
  • hxltech
  • hxltech
  • 2016年05月31日 14:56
  • 1411

往Android Studio中import工程出错时的解决方案

好像很长时间没有倒腾Android相关的x
  • wuxuguang123
  • wuxuguang123
  • 2014年09月06日 09:31
  • 29620

github项目导入Android studio 出现的问题及解决

前言刚用AS的时候,真心觉得坑不要太多,尤其是导入项目的时候,所以特此整理一些错误信息,方便以后查询和修改错误...
  • liuwanyouyue
  • liuwanyouyue
  • 2016年08月02日 11:05
  • 10477

android导入eclipse项目后,gradle版本引起的问题

1.Error:The project is using an unsupported version of the Android Gradle plug-in (0.12.2). The reco...
  • u011570979
  • u011570979
  • 2015年05月18日 16:29
  • 4662

The project 'FeiYueXueTang_Android' may be using a version of Gradle that does not contain the metho

Error:(24, 0) Gradle DSL method not found: 'android()' Possible causes: The project 'FeiYueXueTang_A...
  • lzy2626
  • lzy2626
  • 2016年03月17日 18:04
  • 1456

android 导入gradle项目The project is using an unsupported version of Gradle.

参考:http://stackoverflow.com/questions/22252956/Android-studio-gradle-issue-upgrading-to-version-0-5-...
  • qq327563603
  • qq327563603
  • 2016年05月30日 10:04
  • 1563

How to add -Xlint:unchecked to my Android Gradle based project?

父build.gradle 中添加: allprojects { gradle.projectsEvaluated { tasks.withType(JavaCompile)...
  • u013092053
  • u013092053
  • 2015年08月04日 00:26
  • 411

Gradle DSL method not found: 'android()'Possible causes:may be using a version of Gradle that does n

错误提示: Error:(16, 0) Gradle DSL method not found: 'android()' Possible causes:The project 'Uninstall...
  • lvwenbo0107
  • lvwenbo0107
  • 2016年06月22日 10:28
  • 2779
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:android 导入gradle项目The project is using an unsupported version of Gradle.
举报原因:
原因补充:

(最多只允许输入30个字)