分子量(Molar Mass)

Molar mass

Time limit: 3.000 seconds

An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. Themolar mass of an organic compound is the mass of one mole of the organic compound. The molar mass of an organic compound can be computed from the standard atomic weights of the elements.

\epsfbox{p3900.eps}

When an organic compound is given as a molecular formula, Dr. CHON wants to find its molar mass. A molecular formula, such asC3H4O3, identifies each constituent element by its chemical symbol and indicates the number of atoms of each element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular element, this quantity is indicated using a subscript after the chemical symbol.

In this problem, we assume that the molecular formula is represented by only four elements, `C' (Carbon), `H' (Hydrogen), `O' (Oxygen), and `N' (Nitrogen) without parentheses.

The following table shows that the standard atomic weights for `C', `H', `O', and `N'.

Atomic NameCarbonHydrogenOxygenNitrogen
Standard Atomic Weight12.01 g/mol1.008 g/mol16.00 g/mol14.01 g/mol


For example, the molar mass of a molecular formula C6H5OH is 94.108 g/mol which is computed by 6× (12.01 g/mol) + 6 × (1.008 g/mol) + 1× (16.00 g/mol).

Given a molecular formula, write a program to compute the molar mass of the formula.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case is given in a single line, which contains a molecular formula as a string. The chemical symbol is given by a capital letter and the length of the string is greater than 0 and less than 80. The quantity numbern which is represented after the chemical symbol would be omitted when the number is 1(2$ \le$n$ \le$99).

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line should contain the molar mass of the given molecular formula.

Sample Input 

4 
C 
C6H5OH 
NH2CH2COOH 
C12H22O11

Sample Output 

12.010 
94.108 
75.070 
342.296

分子量

给出一种物质的分子式(不带括号),求分子量。本题中的分子式只包含 4 种原子,分别为C,H,O,N,原子量分别为12.01,1.008,16.00,14.01(单位:g/mol)。例如,C6H5OH的分子量为94.108g/mol。

【分析】

       (分析过程附加在程序的注释中)

用java语言编写程序,代码如下:

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		double[] massArr = new double[26];
		massArr['C' - 'A'] = 12.01;// C 的原子量
		massArr['H' - 'A'] = 1.008;// H 的原子量
		massArr['O' - 'A'] = 16.00;// O 的原子量
		massArr['N' - 'A'] = 14.01;// N 的原子量
		Scanner input = new Scanner(System.in);
		int n = input.nextInt();
		for(int i = 0; i < n; i++) {
			String str = input.next();
			double molarMass = 0;//所求分子量
			String tempNum = "";//原子对应的原子个数(字符串形式)
			char tempChar;//字符串的一个字符
			int num = 1;//原子个数
			
			//从字符串后面往前进行判断。先求出原子的个数,再找到原子个数前面所属的原子
			for(int j = str.length() - 1; j >= 0; j--) {
				tempChar = str.charAt(j);
				if(tempChar >= '0' && tempChar <= '9') {
					tempNum = tempChar + tempNum;
				}
				else {
					if(tempNum.equals("")) //只有一个原子
						num = 1;
					else {
						num = Integer.parseInt(tempNum);//得到原子数
						tempNum = "";
					}
					
					molarMass += massArr[tempChar - 'A'] * num;
				}
			}
			System.out.printf("%.3f\n", molarMass);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值