poj 1562 Oil Deposits 简单dfs

Oil Deposits
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12228 Accepted: 6615

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2
题意是n*m的油田 @代表有油上下左右对角相邻都代表联通(即为一个矿) 输出矿的个数
人生第一题算法题  代码如下
#include<stdio.h>
#include<string.h>
int dx[10]={-1,0,1,-1,1,-1,0,1};
int dy[10]={-1,-1,-1,0,0,1,1,1};//方向
int n,m;
bool map[110][110];
void dfs(int x,int y)
{
    int nx,ny,i;
    map[x][y]=0;
    for(i=0;i<8;i++)
    {
        nx=x+dx[i];
        ny=y+dy[i];
        if(nx>n||ny>m||nx<1||ny<1)
            continue;
        if(map[nx][ny]==1)
            dfs(nx,ny);
    }
}
int main()
{
    int count,i,j;
    char a;
    while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
    {
        memset(map,0,sizeof(map));
        count=0;
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
        {
            scanf(" %c",&a);
            if(a=='@')
                map[i][j]=1;
        }
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
        {
            if(map[i][j])
            {
                dfs(i,j);
            count++;
            }
        }
        printf("%d\n",count);
    }
    return 0;
}


最基础的dfs 想了整整一下午

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值