poj 1056 IMMEDIATE DECODABILITY 字典树

点击打开链接题目链接

IMMEDIATE DECODABILITY
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11125 Accepted: 5269

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight. 

Examples: Assume an alphabet that has symbols {A, B, C, D} 

The following code is immediately decodable: 
A:01 B:10 C:0010 D:0000 

but this one is not: 
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C) 

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable
 
如果有前缀 就not 

没前缀 就is

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
using namespace std;
struct node
{
    node *next[2];
    int end;
    node()
    {
        end=0;
        next[0]=NULL;
        next[1]=NULL;
    }
};
node *head;
int flag=1;
void tree_add(char *str)
{
    node *t,*s=head;
    int i,l,id;
    l=strlen(str);
    int x=0,y=0;
    for(i=0;i<l;i++)
    {
        id=str[i]-'0';
        if(s->next[id]==NULL)
        {
            x=1;
            t=new node ;
            s->next[id]=t;
            s=s->next[id];
        }
        else
        {
            s=s->next[id];
            if(s->end==1)
                y=1;
        }
    }
    s->end=1;
    flag=!y&&x;
}
int main()
{
    char s1[1000][10];
    int i,j;
    i=j=0;
    head=new node ;
    head->end=0;
    head->next[0]=NULL;
    head->next[1]=NULL;
    int count=1;
    while(scanf("%s",s1[i])!=EOF)
    {
        //printf("flag=%d\n",flag);
        if(strcmp(s1[i],"9")==0)
        {
            if(flag)
            {
                printf("Set %d is immediately decodable\n",count++);
            }
            else printf("Set %d is not immediately decodable\n",count++);
            head=new node ;
            head->end=0;
            head->next[0]=NULL;
            head->next[1]=NULL;
            flag=1;
            continue;
        }
        if(flag==0)
        {
            i++;
            continue;
        }
        tree_add(s1[i]);
        i++;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值