PAT 1040 Pop Sequence (25)(模拟stack)

题目

1051. Pop Sequence (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO

解题思路

  • 1.给定一个限制了大小为mstack,和一个序列1 2 ... N,问你能否依靠这个stack输出给出的例子。
  • 2.用stack模拟,共分为俩种情况:
    (1)来了一个数,这个数比堆顶元素大。这样,就必须把从比pre(记录之前已经压入堆的最大的元素)+1到这个数的所有元素都压入堆,这时候如果空间不够就报错,否则就模拟一下,在排出堆顶,并更新pre
    (2)这个数不比堆顶元素大。那么如果相等,则直接排出就是了,如果小,则先输出这个是不可能的了,则报错。

代码

#include<stack>
#include<cstdio>
using namespace std;
int num[1000+5];
int main(int argc, char *argv[])
{
    int m,n,k;
    scanf("%d %d %d",&m,&n,&k);
    while (k--) {
        stack<int> a;
        for (int i = 0; i < n; ++i) {
            scanf("%d",&num[i]);
        }
        int i;
        bool isFindError = false;
        int pre = 0;
        for (i = 0; i < n; ++i) {
            if (!a.empty()) {
                //如果大于堆顶
                if (a.top()<num[i]) {
                    //如果空间不够,报错
                    if (a.size()+num[i]-pre>m) {
                        printf("NO\n");
                        isFindError = true;
                        break;
                    }else {
                        //如果空间够,就模拟一下,先压入,再排出堆顶的
                        for (int j = pre+1; j <= num[i]; ++j) {
                            a.push(j);
                        }
                        pre = a.top();
                        a.pop();
                    }
                }
                //如果小于或等于堆顶
                else {
                    if (a.top()==num[i]) {
                        a.pop();
                    }else {
                        printf("NO\n");
                        isFindError = true;
                        break;
                    }
                }
            }else {
                if (num[i] - pre>m) {
                    printf("NO\n");
                    isFindError = true;
                    break;
                }else {
                    //如果空间够,模拟一下
                    for (int j = pre + 1; j <= num[i]; ++j) {
                        a.push(j);
                    }
                    pre = a.top();
                    a.pop();
                }

            }
        }
        if (!isFindError) {
            printf("YES\n");
        }

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值