hdoj-1513-Palindrome【LCS+滚动数组】

4 篇文章 0 订阅

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4229    Accepted Submission(s): 1444


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
  
  
5 Ab3bd
 

Sample Output
  
  
2
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1074  1025  1510  1501  1024 
 
 
因为N的范围为5000,开二维数组 re[n][n] 一定会超内存,而对于 求LCS的状态方程为:
 
if(s1[i]==s2[j])  re[i][j]  = re[i-1][j-1] +1;
else                re[i][j]  = max(re[i-1][j],re[i][j-1]);
 
 
所以使用滚动数组 只需要开 大小为 re[2] [5000]的数组即可;
 
小技巧==>>  另外初始时求re[0][0]会出现: i-1<0;或j-1<0 ;为了避免这种现象所以求 re[i+1][j+1];
 
#include<iostream>
#include<stdio.h>
#include<string.h>
//#include<math.h>
#include<algorithm>
using namespace std;
int re[2][5000];
char s1[5000],s2[5000];
int n;
int max(int a,int b){
	return a>b?a:b;
}
void LCS(char aa[],char ba[]);
int main()
{
	while(~scanf("%d",&n)){
        scanf("%s",s1);
		strcpy(s2,s1);
		reverse(s2,s2+n);
		s2[n]='\0';
		LCS(s1,s2);
		printf("%d\n",n-re[n%2][n]);
	}
	return 0;
}
void LCS(char s1[],char s2[]){
	int i,j;
	memset(re,0,sizeof(re));
	for(i=0;i<n;++i){
		for(j=0;j<n;++j){//滚动数组
			if(s1[i]!=s2[j])
				re[(i+1)%2][j+1]=max(re[(i+1)%2][j],re[i%2][j+1]);
			else
				re[(i+1)%2][j+1]=re[i%2][j]+1;
		}
	}
}





 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值