POJ - 3111 K Best (二分 + 01分数规划)

K Best
Time Limit: 8000MS Memory Limit: 65536K
Total Submissions: 8586 Accepted: 2203
Case Time Limit: 2000MS Special Judge

Description

Demy has n jewels. Each of her jewels has some value vi and weight wi.

Since her husband John got broke after recent financial crises, Demy has decided to sell some jewels. She has decided that she would keep k best jewels for herself. She decided to keep such jewels that their specific value is as large as possible. That is, denote the specific value of some set of jewels S = {i1i2, …, ik} as

.

Demy would like to select such k jewels that their specific value is maximal possible. Help her to do so.

Input

The first line of the input file contains n — the number of jewels Demy got, and k — the number of jewels she would like to keep (1 ≤ k ≤ n ≤ 100 000).

The following n lines contain two integer numbers each — vi and wi (0 ≤ vi ≤ 106, 1 ≤ wi ≤ 106, both the sum of all vi and the sum of all wi do not exceed 107).

Output

Output k numbers — the numbers of jewels Demy must keep. If there are several solutions, output any one.

Sample Input

3 2
1 1
1 2
1 3

Sample Output

1 2

题意:有n个物品的价值v和重量w,从中选择k个使之单位重量价值最大,并输出选择的序列,

思路两种:公式推导(此处介绍公式推导过程),01分数规划(请百度\(^o^)/ )

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int MAXN = 1e5 + 5;
const int INF = 0x3f3f3f3f;
struct o{
    int v, w;
}O[MAXN];
struct f{
    double x;
    int id;
    bool operator < (const f &p) const{
        return x > p.x;
    }
}F[MAXN];
int n, k;
double A[MAXN];
bool C(double m){
    for(int i = 0;i < n;i ++){
        F[i].x = O[i].v - m * O[i].w;
        F[i].id = i + 1;
    }
    sort(F, F + n);
    double s = 0;
    for(int i = 0;i < k;i ++){
        s += F[i].x;
    }
    return s >= 0;
}
int main(){
    while(~scanf("%d%d", &n, &k)){
        for(int i = 0;i < n;i ++){
            scanf("%d%d", &O[i].v, &O[i].w);
        }
        double lb = 0, ub = MAXN;
        for(int i = 0;i < 50;i ++){
            double mid = (ub + lb) / 2.;
            if(C(mid)){
                lb = mid;
            }
            else{
                ub = mid;
            }
        }
        for(int i = 0;i < k;i ++){
            printf("%d%c", F[i].id, i == k - 1 ? '\n' :' ');
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值