POJ - 1679 The Unique MST(最小生成树是否唯一)

Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u

 Status

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!


判断最小生成树是否唯一,生成一次最小生成树,每次删除原来最小生成树的一条边,再生成最小生成树,如果有与原来的大小相同,就不唯一。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int mnx = 110;
const int mxe = mnx*(mnx - 1) / 2;

struct edge
{
	int u, v, c;
	bool operator <(edge& b)const
	{
		return c < b.c;
	}
}e[mxe];

int fa[mnx];
int n, m;
int MST;
int fMST[mxe];

int find(int t)
{
	if (fa[t] != t) fa[t] = find(fa[t]);
	return fa[t];
}

int kruskal()
{
	sort(e + 1, e + m + 1);
	for (int i = 1; i <= n; i++)
		fa[i] = i;
	int ret = 0;
	int t = 1;
	for (int i = 1; i <= m; i++)
	{
		int u = e[i].u, v = e[i].v, c = e[i].c;
		u = find(u), v = find(v);
		if (u != v)
		{
			ret += c;
			fa[u] = v;
			fMST[t] = i;
			t++;
		}
	}
	return ret;
}

bool isUnique()
{
	sort(e + 1, e + m + 1);
	for (int k = 1; k <= n-1; k++)
	{
		for (int i = 1; i <= n; i++)
			fa[i] = i;
		int ret = 0;
		int tt = 0;
		for (int i = 1; i <= m; i++)
		{
			if (i == fMST[k]) continue;
			int u = e[i].u, v = e[i].v, c = e[i].c;
			u = find(u), v = find(v);
			if (u != v)
			{
				ret += c;
				fa[u] = v;
				tt++;
			}
		}
		if (ret == MST&&tt == n - 1)
			return false;
	}
	return true;
}

int main()
{
	int casen;
	scanf("%d", &casen);
	while (casen--)
	{
		scanf("%d%d", &n, &m);
		int uu, vv, cc;
		for (int i = 1; i <= m; i++)
		{
			scanf("%d%d%d", &uu, &vv, &cc);
			e[i].u = uu;
			e[i].v = vv;
			e[i].c = cc;
		}

		MST = kruskal();

		if (isUnique()) printf("%d\n", MST);
		else printf("Not Unique!\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

这波lucio来全学了

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值