POJ - 1703 Find them, Catch them(种类并查集)

Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u

 Status

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.


题意:输入n和m,代表有n个人和m个询问,n个人分别属于两个帮派,每个询问遵循下面的规则:

A a b要求输出a与b是否在同一个帮派。D a b告诉信息a和b是不同帮派的成员。

这题与种类并查集的经典题目POJ-1182 食物链相似,更简单一些,关系域更新的时候考虑偏移量和向量的加减,可以得出公式。

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

const int MAXN = 100100;
int fa[MAXN];
int gang[MAXN];
int n, k;

void init()
{
	for (int i = 0; i <= n; i++)
	{
		fa[i] = i;
		gang[i] = 0;
	}
}

int find(int t)
{
	if (fa[t] == t)
		return fa[t];
	int temp = fa[t];
	fa[t] = find(temp);
	gang[t] = (gang[t] + gang[temp]) % 2;
	return fa[t];
}

void union_set(int a, int b)
{
	int roota = find(a);
	int rootb = find(b);
	if (roota != rootb)
	{
		fa[rootb] = roota;
		gang[rootb] = (gang[a] + 1 - gang[b]) % 2;
	}
}

int solve(int a, int b)
{
	int roota = find(a);
	int rootb = find(b);
	if (roota != rootb)
	{
		return 1;
	}
	else
	{
		if (gang[a] != gang[b])
			return 2;
		else
			return 3;
	}
}

int main()
{
	int casen;
	scanf("%d", &casen);
	while (casen--)
	{
		scanf("%d%d", &n, &k);
		init();
		char op;
		int a, b;
		for (int i = 0; i < k; i++)
		{
			cin >> op;
			scanf("%d%d", &a, &b);
			if (op == 'D')
			{
				union_set(a, b);
			}
			else
			{
				int ret = solve(a, b);
				if (ret == 1)
					printf("Not sure yet.\n");
				else if (ret == 2)
					printf("In different gangs.\n");
				else
					printf("In the same gang.\n");
			}
		}
	}
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

这波lucio来全学了

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值