HDU - 2141 Can you find it?(二分查找)



Time Limit: 3000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u

 Status

Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 
 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 
 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 
 

Sample Input

    
    
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output

    
    
Case 1: NO YES NO
 


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int a[600], b[600], c[600];
int sum[300000];
int l, n, m;

bool binary_search(int x)
{
	int l = 0, r = n*m - 1, m;
	while (l <= r)
	{
		m = (l + r) >> 1;
		if (x == sum[m]) return true;
		if (x < sum[m]) r = m - 1;
		else l = m + 1;
	}
	return false;
}

int main()
{
	int cas = 1;
	while (scanf("%d%d%d", &l, &n, &m) != EOF)
	{
		for (int i = 0; i < l; i++)
			scanf("%d", &a[i]);
		for (int i = 0; i < n; i++)
			scanf("%d", &b[i]);
		for (int i = 0; i < m; i++)
			scanf("%d", &c[i]);

		int ji = 0;
		for (int i = 0; i < n; i++)
		for (int j = 0; j < m; j++)
			sum[ji++] = b[i] + c[j];

		sort(sum, sum + ji);

		int query, num;
		scanf("%d", &query);

		printf("Case %d:\n", cas++);

		for (int q = 0; q < query; q++)
		{
			scanf("%d", &num);
			bool ret = false;
			for (int i = 0; i < l; i++)
			{
				if (binary_search(num - a[i]))
				{
					ret = true;
					break;
				}
			}
			if (ret) printf("YES\n");
			else printf("NO\n");
		}
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

这波lucio来全学了

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值