贪心--HDU - 4442 Physical Examination

Input

There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues). 
Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue: 
1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject. 
2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue. 
The input ends with n = 0. 
For all test cases, 0<n≤100000, 0≤a  i,b  i<2  31.
 

Output

For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.
 

Sample Input

    
    
5 1 2 2 3 3 4 4 5 5 6 0
 

Sample Output

    
    
1419


分析:假如有两个队列,a1 b1 a2 b2,先选队列1的时间: a1 + a1*b2 + a2 先选队列2的时间:a2 + a2*b1 + a1

对比发现只有 a1*b2 和 a2*b1不同。


#include <cstdio>
#include <algorithm>

using namespace std;
typedef long long LL;
const int maxn = 100000 + 10;
const int mod = 365*24*60*60;
struct Node { LL x, y; } p[maxn];

bool cmp(const Node& a, const Node& b)
{
    return a.x*b.y < a.y*b.x;
}

int main()
{
	int n;
	while(scanf("%d", &n), n) {
		for(int i=0; i<n; i++) scanf("%lld%lld", &p[i].x, &p[i].y);
		sort(p, p+n, cmp);
		LL sum = p[0].x;
		for(int i=1; i<n; i++) {
			sum = (sum + sum*p[i].y + p[i].x)%mod;
		}
		printf("%lld\n", sum);
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值