PAT甲级1023

1023. Have Fun with Numbers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798
#include<cstdio>
#include<vector>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	char s[22];
	scanf("%s", s);
	int hash[10] = { 0 };
	int len = strlen(s);
	for (int i = 0; i < len; i++)
	{
		hash[s[i] - '0']++;
	}
	int t, carry = 0,dt;
	bool flag = false;
	for (int i = len - 1; i >= 0; i--)
	{
		t = s[i] - '0';
		dt = t << 1;
		if (dt >= 10)
		{
			s[i] = '0' + dt - 10+carry;
			carry = 1;
		}
		else
		{
			s[i] = '0' + dt+carry;
			carry = 0;
		}
		if (i == 0 && carry)
			flag = true;
	}
	for (int i = 0; i < len; i++)
	{
		hash[s[i] - '0']--;
	}
	
	if (flag)
	{
		printf("No\n");
		printf("1");//这个地方得注意,由于不管是No,还是Yes都要输出翻倍后的数,即使数字长度不同
		printf("%s", s);
		return 0;
	}
	else
	{
		for (int i = 0; i < len; i++)
		{
			if (hash[s[i] - '0'] != 0)
			{
				printf("No\n");
				printf("%s", s);
				return 0;
			}
		}
	}
	printf("Yes\n");
	printf("%s", s);
	return 0;
}
/*一定要先弄清楚题意,不要有个大概的思路就开始写。题目完全弄懂,把可能出现的坑点想清楚,算法思想一定要清晰然后在开始动手写,模糊的话就不要开始写
因为最后会漏洞百出。*/




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值